need advice

Reply

Old 03-17-2009, 09:31 PM
  #1  
Tech Rookie
Thread Starter
 
ntc3bionicracer's Avatar
 
Join Date: Jan 2009
Location: mandeville,la.
Posts: 18
Default need advice

i have a used revo 2.5 it runs at idel or a little above idel but spits a mist of fuel out of the carb when engine is runnining and only runs for 2-4 minutes i can pull the muffler pipe off and it has a build up of fuel in it enought to drain some out. i even tried to cut the fuel flow adjustment way down like just enough to run engine and got the low air speed set at best to run a little pass idel. is it the carb or engine the problem.??
ntc3bionicracer is offline  
Reply With Quote
Old 03-17-2009, 09:40 PM
  #2  
Tech Master
iTrader: (5)
 
snowboard094's Avatar
 
Join Date: Jan 2009
Location: Sac Town CA
Posts: 1,974
Trader Rating: 5 (100%+)
Default

Originally Posted by ntc3bionicracer View Post
i have a used revo 2.5 it runs at idel or a little above idel but spits a mist of fuel out of the carb when engine is runnining and only runs for 2-4 minutes i can pull the muffler pipe off and it has a build up of fuel in it enought to drain some out. i even tried to cut the fuel flow adjustment way down like just enough to run engine and got the low air speed set at best to run a little pass idel. is it the carb or engine the problem.??
This shouldn't be a problem with your engine or carb it is just out of tune. Lean the low speed needle.
snowboard094 is offline  
Reply With Quote
Old 03-17-2009, 10:00 PM
  #3  
Tech Master
iTrader: (32)
 
VenturaDC's Avatar
 
Join Date: Oct 2007
Location: Ventura, SoCal
Posts: 1,131
Trader Rating: 32 (100%+)
Default

search up the factory needle settings, reset and tune from there.
VenturaDC is offline  
Reply With Quote
Old 03-17-2009, 10:36 PM
  #4  
Tech Rookie
Thread Starter
 
ntc3bionicracer's Avatar
 
Join Date: Jan 2009
Location: mandeville,la.
Posts: 18
Default need advise

i've done that,, it just seems its getting too much fuel,,, low screw even with scew houseing and high speed 4-turns out,,thanks for your help
ntc3bionicracer is offline  
Reply With Quote
Old 03-18-2009, 03:43 AM
  #5  
Tech Fanatic
iTrader: (1)
 
Join Date: Jan 2008
Location: All Over So. Fla.
Posts: 985
Trader Rating: 1 (100%+)
Default

I know this sounds weard but check the pipe real well. Could be clogged or bent at the wrong spot or leaking. Had a frends one that was cracked at the nipple for the tank line. JB Weld and rocks now.
The Working Man is offline  
Reply With Quote
Old 03-18-2009, 04:24 AM
  #6  
Tech Elite
iTrader: (52)
 
rcracenut's Avatar
 
Join Date: Sep 2004
Location: WIS
Posts: 3,363
Trader Rating: 52 (96%+)
Default

Originally Posted by ntc3bionicracer View Post
i've done that,, it just seems its getting too much fuel,,, low screw even with scew houseing and high speed 4-turns out,,thanks for your help
4 turns sounds like too much. Turn it 3 turns from slightly seated. I would start at 2- 2.5 turns out for the idle mixture. How much compression does it have? Can you feel a definate resistance when it come to the top of the stroke?
rcracenut is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service