Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
Engine cuts off when i brake >

Engine cuts off when i brake

Engine cuts off when i brake

Reply

Old 03-10-2009, 09:00 AM
  #1  
Tech Initiate
Thread Starter
 
joeduffy987's Avatar
 
Join Date: Feb 2009
Posts: 27
Default Engine cuts off when i brake

The engine cuts off when i break even if just slightly any help any Pictures that can help would be greatly appreciated.
joeduffy987 is offline  
Reply With Quote
Old 03-10-2009, 09:04 AM
  #2  
Tech Master
iTrader: (2)
 
Charles Godwin's Avatar
 
Join Date: May 2005
Location: UK (England)
Posts: 1,133
Trader Rating: 2 (100%+)
Default

Your idle screw is to far out. Turn it in more and it'll cure the problem
Charles Godwin is offline  
Reply With Quote
Old 03-10-2009, 09:05 AM
  #3  
Tech Master
iTrader: (8)
 
SkarTisu's Avatar
 
Join Date: Sep 2001
Location: Minnesota
Posts: 1,671
Trader Rating: 8 (100%+)
Default

It could be a few things:

- Idle is too low
- Low speed needle is too rich
- Clutch is hanging up
SkarTisu is offline  
Reply With Quote
Old 03-10-2009, 09:12 AM
  #4  
Tech Initiate
Thread Starter
 
joeduffy987's Avatar
 
Join Date: Feb 2009
Posts: 27
Default

Thanks guys =D
joeduffy987 is offline  
Reply With Quote
Old 03-10-2009, 03:28 PM
  #5  
Tech Addict
 
RETRO RC's Avatar
 
Join Date: Jan 2007
Location: AUCKLAND NEW ZEALAND
Posts: 715
Default

Originally Posted by joeduffy987 View Post
The engine cuts off when i break even if just slightly any help any Pictures that can help would be greatly appreciated.
If it's cutting out when you only just touch the brakes then it more than likely the clutch, check your bearings and springs

Adrian
RETRO RC is offline  
Reply With Quote
Old 03-10-2009, 07:00 PM
  #6  
Tech Regular
iTrader: (6)
 
Join Date: Feb 2009
Posts: 459
Trader Rating: 6 (100%+)
Default

I have this problem but only after a long full throttle straight away, come to the end and brake and the motor dies. Thinking it is the clutch and had plans to change to the metal shoes. Hope it works
Giulitto is offline  
Reply With Quote
Old 03-11-2009, 02:22 AM
  #7  
Tech Fanatic
iTrader: (1)
 
Join Date: Jan 2008
Location: All Over So. Fla.
Posts: 985
Trader Rating: 1 (100%+)
Default

Originally Posted by Giulitto View Post
I have this problem but only after a long full throttle straight away, come to the end and brake and the motor dies. Thinking it is the clutch and had plans to change to the metal shoes. Hope it works
In your case I think it my be the tuning. To fat lsn, to high idle. Do a pinch test at 1/2 in. fuel inlet at carb. Should die around 3-4 sec. Talk to the old farts at the track.
The Working Man is offline  
Reply With Quote
Old 03-11-2009, 04:26 PM
  #8  
Tech Master
 
pitpop's Avatar
 
Join Date: Mar 2006
Posts: 1,445
Default

did you get this resolved, is your rig running right now?
pitpop is offline  
Reply With Quote
Old 03-11-2009, 07:59 PM
  #9  
Tech Regular
iTrader: (17)
 
rced1's Avatar
 
Join Date: Jan 2005
Location: Illinois
Posts: 336
Trader Rating: 17 (100%+)
Default

Originally Posted by RETRO RC View Post
If it's cutting out when you only just touch the brakes then it more than likely the clutch, check your bearings and springs

Adrian
Also check the trim on the throttle servo. There should be a little space or slack before the servo horn starts moving the throttle arm. If the throttle arm moves in when you apply the brake then the trim and idle screw both needs to be adjusted.
rced1 is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service