Losi 2.0 Body FYI

Reply

Old 03-15-2009, 11:53 PM
  #16  
Tech Elite
Thread Starter
iTrader: (8)
 
dishsoap's Avatar
 
Join Date: Jan 2009
Location: Tucson, AZ
Posts: 2,460
Trader Rating: 8 (100%+)
Default

Originally Posted by bastard dsm View Post
be sure to dremel the rear hole some more on the body if your putting it on a 1.0. although its ovaled already, on the 1.0 the rear mount sits right at the front of the hole. since the 2.0 is 2mm longer the rear mount sits right in the middle. i found this out the hard way, after a few bad jumps with my car landing smack center on the chassis. the flex ripped my 2.0 body around the front mounting hole.
Good advice. Yeh I made sure I got a good fit. Also you are suposed to use the plastic piece that comes with the body for a tighter fit when putting the clips on.
dishsoap is offline  
Reply With Quote
Old 03-16-2009, 08:22 AM
  #17  
Tech Lord
iTrader: (8)
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,484
Trader Rating: 8 (100%+)
Default

Originally Posted by dishsoap View Post
Good advice. Yeh I made sure I got a good fit. Also you are suposed to use the plastic piece that comes with the body for a tighter fit when putting the clips on.

i would think so ya....I dont use mine however....as my clips are tight already due to my shell beefing up i do...i could never get the clip though with both lexan and silicone under the hole...its just too tight...
Integra is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service