Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
kyosho inferno sport 3 problem >

kyosho inferno sport 3 problem

kyosho inferno sport 3 problem

Old 03-06-2009, 02:47 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Dec 2008
Posts: 18
Default kyosho inferno sport 3 problem

hi i have had my kyosho since christmas and i havent been able to get it running properly since then as when i get it started it just bogs down or when i apply a bit of throttle it revs then bogs and cuts out

i have tried leaning it a little but no joy, could i t be a air leak or something

I dont know but i f someone could get back 2 me that would be greatful


thanks
hypergpx4 is offline  
Old 03-06-2009, 03:45 AM
  #2  
Tech Apprentice
 
NRGman's Avatar
 
Join Date: Jun 2008
Posts: 54
Default

Reset all needles back to factory settings (Should be in the user manual) then lean the low and high speed needles until it starts to run crappy, then back off a 1/8th of a turn on both needles
NRGman is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.