Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
Glow plug issue >

Glow plug issue

Glow plug issue

Old 12-18-2008, 06:55 PM
  #1  
Suspended
Thread Starter
 
Join Date: Oct 2008
Posts: 51
Default Glow plug issue

I keep on changing my glow plug after every 3 tanks is that normal??? there is a good amount of smoke coming out and you can easily tell that its rich. And im using traxxas glow plugs and maybe thats an issue
usa98030 is offline  
Old 12-18-2008, 08:08 PM
  #2  
Tech Adept
iTrader: (1)
 
Join Date: Dec 2008
Location: lincoln ne
Posts: 168
Trader Rating: 1 (60%+)
Default

what engine u runing. and what % of fuel u using. in what kind of car. thanks nate
mungen is offline  
Old 12-18-2008, 08:20 PM
  #3  
Tech Addict
iTrader: (57)
 
Tiggertrucks's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 638
Trader Rating: 57 (98%+)
Default

there is three possibility's 1 its too rich on top and too lean on bottom 2 its too rich all the way around or 3 you have a mechanical issue( dirt in the engine or plug too long
Tiggertrucks is offline  
Old 12-18-2008, 08:29 PM
  #4  
Tech Champion
iTrader: (17)
 
JAMMINKRAZY's Avatar
 
Join Date: Jun 2007
Location: Pittsburgh PA
Posts: 6,575
Trader Rating: 17 (100%+)
Default

Originally Posted by Tiggertrucks View Post
there is three possibility's 1 its too rich on top and too lean on bottom 2 its too rich all the way around or 3 you have a mechanical issue( dirt in the engine or plug too long
+1 or it could even be a bad bearing or sloppy con rod bushing.
JAMMINKRAZY is offline  
Old 12-18-2008, 08:32 PM
  #5  
Tech Regular
iTrader: (20)
 
RickBac's Avatar
 
Join Date: Nov 2006
Location: Anthem, AZ
Posts: 344
Trader Rating: 20 (100%+)
Default

what does the plug look like after it is fouled? That should help decide if it is too rich too lean etc.
RickBac is offline  
Old 12-19-2008, 11:32 AM
  #6  
Suspended
Thread Starter
 
Join Date: Oct 2008
Posts: 51
Default

The glow plug looks pretty good but at the edge of the glow plug it looks like a piece of filament is broken. And im using 20% traxxas fuel, 2.5 traxxas engine, and in a nitro rustler. I think it was to rich at the top and to lean at the bottome but people help me out because i killed glow plug after trying to start up my car!! Like the glow plug led just went of after the engine just kept spinning. AND THIS ENGINE HAS ONLY 8 TANKS AFTER BREAK IN!!!!
usa98030 is offline  
Old 12-19-2008, 11:35 AM
  #7  
Tech Champion
iTrader: (17)
 
JAMMINKRAZY's Avatar
 
Join Date: Jun 2007
Location: Pittsburgh PA
Posts: 6,575
Trader Rating: 17 (100%+)
Default

If the filament is blown out it could easily be a bearing or con rod. See if you have slop in a bearing or conrod it can cause the piston to travel slightly too high in the sleeve causing excessive compression that blows the element right out. I would check bearings and rod for slop. just my 2 cents worth.
JAMMINKRAZY is offline  
Old 12-19-2008, 11:38 AM
  #8  
Tech Elite
iTrader: (55)
 
jpalessi's Avatar
 
Join Date: Feb 2008
Location: SoCal
Posts: 4,747
Trader Rating: 55 (100%+)
Default

what glow plug?? traxxas requires a long body plug...
jpalessi is offline  
Old 12-19-2008, 11:41 AM
  #9  
Tech Champion
iTrader: (17)
 
JAMMINKRAZY's Avatar
 
Join Date: Jun 2007
Location: Pittsburgh PA
Posts: 6,575
Trader Rating: 17 (100%+)
Default

Originally Posted by jpalessi View Post
what glow plug?? traxxas requires a short body plug...
I thought traxxas plugs were long body plugs. way back when I had a t-maxx I ran traxxas standard long(medium) plugs.
this is what I used

http://www.amainhobbies.com/product_...ducts_id/11205

this one says for 2.5
http://www.amainhobbies.com/product_...oducts_id/2125
JAMMINKRAZY is offline  
Old 12-19-2008, 11:49 AM
  #10  
Tech Elite
iTrader: (55)
 
jpalessi's Avatar
 
Join Date: Feb 2008
Location: SoCal
Posts: 4,747
Trader Rating: 55 (100%+)
Default

Originally Posted by JAMMINKRAZY View Post
I thought traxxas plugs were long body plugs. way back when I had a t-maxx I ran traxxas standard long(medium) plugs.
this is what I used

http://www.amainhobbies.com/product_...ducts_id/11205

this one says for 2.5
http://www.amainhobbies.com/product_...oducts_id/2125
Your right... my bad....hadn't ran a traxxas since i worked in a hobby shop a few years ago.. I ran an OS 18 in mine with a turbo button.
jpalessi is offline  
Old 12-19-2008, 12:31 PM
  #11  
Suspended
Thread Starter
 
Join Date: Oct 2008
Posts: 51
Default

im using a super duty long medium with gasket glow plug.
usa98030 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.