Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
HPI Trophy Truggy 4.6 >

HPI Trophy Truggy 4.6

HPI Trophy Truggy 4.6

Reply

Old 04-01-2019, 10:40 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Apr 2019
Posts: 7
Questions?? HPI Trophy Truggy 4.6

Hello guys, i have HPI Trophy Truggy 4.6 nitro off-road which i haven't been using for 6 years or so. Eventually i wanted to run it once again so i disassembled the engine. Cleaned all the parts, piston, sleeve, crankshaft, bearings, carburetor... But the problem here is when i was trying to take the sleeve out, i scratched it a lil bit. My friend's father who is auto-repairer fixed it by grinding it gently. Then we oiled the parts and assembled back. I tried to start the engine with my 6 years old fuel. Which i succeeded it on rich carb settings. The problem here is i can't get a performance. Engine's performance is like %50 or sth. I tried to tune and at some point the performance was like %80-85 which is not too bad for me but it didn't last long. (like %50-60 of the fuel tank) And every tank, at the end of the tank car reaches almost the %90-100 performance. But only at the end of the tank. I bought a new fuel and it is %25, i was using %20 before.

So what might be the problem, first i thought i damaged the engine but i saw a satisfying performance for a bit even with the 6 years old fuel. And as i said car reaches almost the top speed at the and of the tank while the engine is about to die.
Frenzi3d is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service