Go Back  R/C Tech Forums > General Forums > Monster Trucks
TEAM LOSI LST official thread >

TEAM LOSI LST official thread

Like Tree4Likes

TEAM LOSI LST official thread

Old 08-13-2005, 10:19 PM
  #16  
Tech Master
iTrader: (4)
 
subman's Avatar
 
Join Date: Jan 2004
Location: Edmonton,Canada
Posts: 1,237
Trader Rating: 4 (100%+)
Default

I just bought a used LST and I was driving it for the first time and it pops in and out of gear I was wondering if this is common or anyone has ever come across this.
subman is offline  
Old 08-13-2005, 11:05 PM
  #17  
Tech Adept
 
miks vones2's Avatar
 
Join Date: Jun 2004
Location: melbourne, australia
Posts: 222
Default

hello fellow LSTers,

bout time someone started an LST thread.

i am just a backyard basher for offroad, but race onroad. i love to take out the LST and give her a hiding and socialy race anyone who wants a fun day out.

i am very interested in the forward only kit. what is the actual proformance difference? is it really a great buy? i dont use reverse that often (usually forget i even have it....too long running nitro cars.lol)

the upgrades i hav made so far are the essentials like alloy diff housings, secondary gear cover, and the heavier "yelloe" springs.

i want to buy a nice set of tyres/rims for it but dont want to change the diameter (i like the stock gear ratio) so what do you guys recommend. im running on hard packed surface with a light sandy covering (quite slippery) proline badlands work really well on my buggy, is there an equal for the LST?

thanx guys, chat soon
miks vones2 is offline  
Old 08-13-2005, 11:10 PM
  #18  
Tech Adept
 
miks vones2's Avatar
 
Join Date: Jun 2004
Location: melbourne, australia
Posts: 222
Default

Originally Posted by subman
I just bought a used LST and I was driving it for the first time and it pops in and out of gear I was wondering if this is common or anyone has ever come across this.
i have heard the clutch springs are a problem. maybe start there.

then maybe check that nothing has come loose or broken in the centre gearbox.

goodluck
miks vones2 is offline  
Old 08-14-2005, 06:26 AM
  #19  
Tech Regular
iTrader: (3)
 
Join Date: Oct 2004
Posts: 339
Trader Rating: 3 (100%+)
Default

yeah i had the same prob, turned out the reverse servo was bad was letting
pop in and out of the foward gear. i did the foward only conversion but before
that i used a spring to keep the tension on the shift arm and that solved it!!!
reddishdsb is offline  
Old 08-14-2005, 07:59 AM
  #20  
Tech Adept
 
mike m's Avatar
 
Join Date: Jan 2004
Location: Langley, BC
Posts: 179
Talking

I had a prob with the diffs as well........when I put the Collari in it anyways. I just got a killer deal on some Weld Racing rims and tires for the 23mm adapters from Pro_line and have the sway bars on order. I haven't bother with the springs yet but know I will be soon enough.
mike m is offline  
Old 08-14-2005, 09:52 AM
  #21  
Tech Master
iTrader: (4)
 
subman's Avatar
 
Join Date: Jan 2004
Location: Edmonton,Canada
Posts: 1,237
Trader Rating: 4 (100%+)
Default

Originally Posted by reddishdsb
yeah i had the same prob, turned out the reverse servo was bad was letting
pop in and out of the foward gear. i did the foward only conversion but before
that i used a spring to keep the tension on the shift arm and that solved it!!!
I was thinking that the forward only conversion was the way to go. (not used to reverse anyway)

Thanks for the help I'll post up what was wrong when I find out.
subman is offline  
Old 08-14-2005, 06:15 PM
  #22  
Tech Regular
iTrader: (3)
 
Join Date: Oct 2004
Posts: 339
Trader Rating: 3 (100%+)
Default

10/4
reddishdsb is offline  
Old 08-14-2005, 06:17 PM
  #23  
Tech Regular
iTrader: (3)
 
Join Date: Oct 2004
Posts: 339
Trader Rating: 3 (100%+)
Default

What do I have to do to post pics on here?
reddishdsb is offline  
Old 08-14-2005, 09:53 PM
  #24  
Tech Adept
iTrader: (7)
 
Join Date: Jul 2005
Location: Madera, CA
Posts: 102
Trader Rating: 7 (100%+)
Default Nice Truck!

Hey stevenmichael,

Nice Truck. Looks like you are going with a single servo setup. My project is very near completion as well. By the time I get back from this business trip I should have a Hitec HSC-5955TG 333 waiting so I can complete it. I also opted for the Novarossi after the Mach disintegrated on the 3rd break in tank. I had a Sirio .30 from Tower but couldn't find a suitable pipe so I sent it back and picked up the NR. I also found a setup for a rotostart from Crispy Critters. The new RPM gear cover got installed this morning before I jumped on a plane for Portland. This is a sweet setup. Beats the heck out of the lexan part from Losi. I'll work on posting some shots here next week. Since I did extensive research in the forums when building it I plan to document the whole process at the "soon to be released" www.projectlst.com and include links to the best ideas I came across. I'm guessing I'll see you at the Hobbytown USA track in Madera in a couple of weeks. I hear there will be an all day event sometime this month.

dirtdemon
dirtdemon is offline  
Old 08-14-2005, 10:03 PM
  #25  
Tech Elite
Thread Starter
iTrader: (34)
 
stevenmichael's Avatar
 
Join Date: Apr 2005
Location: fresno,ca
Posts: 2,142
Trader Rating: 34 (95%+)
Default

Originally Posted by dirtdemon
Hey stevenmichael,

Nice Truck. Looks like you are going with a single servo setup. My project is very near completion as well. By the time I get back from this business trip I should have a Hitec HSC-5955TG 333 waiting so I can complete it. I also opted for the Novarossi after the Mach disintegrated on the 3rd break in tank. I had a Sirio .30 from Tower but couldn't find a suitable pipe so I sent it back and picked up the NR. I also found a setup for a rotostart from Crispy Critters. The new RPM gear cover got installed this morning before I jumped on a plane for Portland. This is a sweet setup. Beats the heck out of the lexan part from Losi. I'll work on posting some shots here next week. Since I did extensive research in the forums when building it I plan to document the whole process at the "soon to be released" www.projectlst.com and include links to the best ideas I came across. I'm guessing I'll see you at the Hobbytown USA track in Madera in a couple of weeks. I hear there will be an all day event sometime this month.

dirtdemon
hey dirtdemon,
have you raced out at the madera track yet? if so whats your name if you dont mind me asking?

im going with 2 5945 hitecs my other lst had 5645 and i worked fine but i want something a little faster so im going with these.

do you have a web site for the crispy critters starter? i found a way to make the mach 26 one work but it will require machine work.

i went to ti ni gear set from losi and havent had a problem i even took off the cover i made for it and have 3 races on it without so much as a mark on them.

i like the nr but it doesnt seem to be as much of a screamer as the mach for some reason the truck loves that mach.

you will have to come out next fri. we are having a play race day(we just redesigned the track today) and the following fri. we are starting a new points series(5 week)
steven
stevenmichael is offline  
Old 08-14-2005, 10:05 PM
  #26  
Tech Elite
Thread Starter
iTrader: (34)
 
stevenmichael's Avatar
 
Join Date: Apr 2005
Location: fresno,ca
Posts: 2,142
Trader Rating: 34 (95%+)
Default

Originally Posted by JWRockman
With the stock Mach .26, what clutch shoe and spring setup do you all have. By the way I have purchased the XTM slider clutch but haven't put it on yet.
Let me know what 3 shoe setup you use.
JWRockman
all i have ever run is the stock setup,i had a problem early but it was resolved and havent had a problem since.

i do plan on going to the new alum. shoes they have coming out and mugen 1.1 springs i used this setup in my mayhem with great results
steven
stevenmichael is offline  
Old 08-14-2005, 10:08 PM
  #27  
Tech Elite
Thread Starter
iTrader: (34)
 
stevenmichael's Avatar
 
Join Date: Apr 2005
Location: fresno,ca
Posts: 2,142
Trader Rating: 34 (95%+)
Default

Originally Posted by reddishdsb
What do I have to do to post pics on here?
at the bottom of the post page when your filling out what you want to say,it says additional options click on manage attachments then you will browse for the pics you want and up load em.
steven
stevenmichael is offline  
Old 08-14-2005, 11:12 PM
  #28  
Tech Adept
 
miks vones2's Avatar
 
Join Date: Jun 2004
Location: melbourne, australia
Posts: 222
Default

Originally Posted by stevenmichael
at the bottom of the post page when your filling out what you want to say,it says additional options click on manage attachments then you will browse for the pics you want and up load em.
steven
or you will need to host the pics and use [img]web address here[/img] tags.

there are a few free hosting sites around. www.rcpics.com seems to be popular.

just remember that most free hosting sites work on the policy that the uploaded images basically become their property also, and they can use them for their own purposes.
miks vones2 is offline  
Old 08-15-2005, 02:07 PM
  #29  
Tech Addict
iTrader: (17)
 
1 Xtreme R/C's Avatar
 
Join Date: Jun 2004
Location: Walla Walla, WA
Posts: 520
Trader Rating: 17 (100%+)
Default

Originally Posted by JWRockman
With the stock Mach .26, what clutch shoe and spring setup do you all have. By the way I have purchased the XTM slider clutch but haven't put it on yet.
Let me know what 3 shoe setup you use.
JWRockman
This is what I'm using, same ones have made it sevral big race weekends and lots of club racing.

Kyosho shoes Part #-IFW52

Kyosho sprigs Part #-IFW53M

The stock ones are junk, I broke 2 of the 3 springs before I had a gallon through it.
1 Xtreme R/C is offline  
Old 08-15-2005, 02:48 PM
  #30  
Tech Adept
iTrader: (7)
 
Join Date: Jul 2005
Location: Madera, CA
Posts: 102
Trader Rating: 7 (100%+)
Default Madera Track

All the time. I have been running a Yellow Jeep T-maxx. I flipped it in practice last Friday and broke stuff so we went home early. I won't get home from Portland until late Friday so I'll miss that one.

Here is the link to the parts for the rotostart.

http://www.crispycrittershobbyshop.c...me.php?cat=455

You need the following

RBC1900-121 Back plate
87123 HPI 12/15 back plate
87118 HPI gear set
ofna 51322 pullstart axle

The HPI backplate will need a slight amount of filing inside the mounting holes. Other then that it works great.

Rick
dirtdemon is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.