Go Back  R/C Tech Forums > General Forums > Monster Trucks
REVO MOVES BY IT SELF >

REVO MOVES BY IT SELF

REVO MOVES BY IT SELF

Old 12-23-2010, 10:18 AM
  #16  
Tech Initiate
Thread Starter
 
Join Date: Nov 2010
Posts: 45
Default

I know I had to adjust the steerin servo horns after installing new radio hopefully that's it
impala_man2003 is offline  
Old 12-23-2010, 10:38 AM
  #17  
Tech Lord
iTrader: (21)
 
Join Date: Jul 2008
Location: Houston, TX
Posts: 11,530
Trader Rating: 21 (100%+)
Default

Won't know til you try, but it should be easy to find out.
Duster_360 is offline  
Old 12-23-2010, 10:17 PM
  #18  
Tech Initiate
Thread Starter
 
Join Date: Nov 2010
Posts: 45
Default

i finally figured out what was causing me all the problems THE SPRING AROUND TYHE CLUTCH SHOES BROKE JUST REPLACED IT WILL LET U GUYS KNOW WHAT HAPPENS WHEN I RUN IT IN THE MORNING
impala_man2003 is offline  
Old 12-24-2010, 08:03 AM
  #19  
Tech Lord
iTrader: (21)
 
Join Date: Jul 2008
Location: Houston, TX
Posts: 11,530
Trader Rating: 21 (100%+)
Default

Cool, that makes sense. Should be good to go.
Duster_360 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.