Go Back  R/C Tech Forums > General Forums > Monster Trucks
Revo 2.5 and Robinson Racing Gears Issue >

Revo 2.5 and Robinson Racing Gears Issue

Revo 2.5 and Robinson Racing Gears Issue

Old 04-10-2008, 08:34 PM
  #1  
Tech Addict
Thread Starter
iTrader: (53)
 
Pauly6401's Avatar
 
Join Date: Mar 2008
Location: Arlington, VA
Posts: 673
Trader Rating: 53 (100%+)
Default Revo 2.5 and Robinson Racing Gears Issue

I am converting a 2.5 Revo to brushless and I picked up the Tekno Conversion Kit as well as the complete Robinson Racing Gears set. The transmission had already been converted to forward only when I bought the car as a roller. I set about installing the gears tonight.

When I got to the forward only portion, the metal gear doesn't seem like it is slipping down far enough over the gearshaft, and it also seems like something is too long because the transmission case doesn't want to fit all the way back together again. I know it has to fit, because the transmission was already together with the forward only conversion and all I did was replace the gears with metal ones. Does anyone have experience doing this, and can give me some tips? Even with the Traxxas forward conversion instructions, exploded view, and an RC Driver article covering how to do this, I still can't get it right and it's stumping me.

This is the first time I've had the tranny apart, and I'd like to get it back together. I'll take some pics tomorrow, but any help (or pictures of yours) would be appreciated. Thanks!
Pauly6401 is offline  
Old 04-11-2008, 05:25 AM
  #2  
Tech Addict
Thread Starter
iTrader: (53)
 
Pauly6401's Avatar
 
Join Date: Mar 2008
Location: Arlington, VA
Posts: 673
Trader Rating: 53 (100%+)
Default

I think I solved my own problem as I was trying to fall asleep last night. Traxxas forward only conversion uses a new shaft and gears. The Robinson Racing gears are made to work with the stock Revo shaft, so they don't fit right on the forward only conversion shaft. Problem should be solved once I pick up a new stock shaft.

Just posted this in case anyone else ever has the same problem and they find this thread.
Pauly6401 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.