Go Back  R/C Tech Forums > General Forums > Micro and Mini Scales
TrackStar 1/18th 12T combo >

TrackStar 1/18th 12T combo

TrackStar 1/18th 12T combo

Reply

Old 02-08-2015, 07:31 PM
  #1  
Tech Adept
Thread Starter
iTrader: (5)
 
Join Date: Feb 2010
Posts: 189
Trader Rating: 5 (100%+)
Default TrackStar 1/18th 12T combo

I got one of these and it lasted for about 3 minutes before it started cogging badly and shortly after that it quit all together. I had it mounted in a RC18T2 I got off of eBay. I fixed all the binding issues before mounting this motor. Has anyone else had any experiences with these combos?
BrianTx01 is offline  
Reply With Quote
Old 02-08-2015, 07:57 PM
  #2  
Tech Elite
 
Join Date: Mar 2006
Posts: 2,226
Default

I actually just bought two 1/18 trackstar combos for my minis. Haven't used them yet cause we race in the summer months. My buddy bought one last year for his mini 8ight, he loved it! I've also read TONS of posts with positive feedback. That's why I decided to buy a couple of them.
vines is offline  
Reply With Quote
Old 02-08-2015, 08:29 PM
  #3  
Tech Adept
Thread Starter
iTrader: (5)
 
Join Date: Feb 2010
Posts: 189
Trader Rating: 5 (100%+)
Default

I guess I will have them send me another.
BrianTx01 is offline  
Reply With Quote
Old 02-09-2015, 08:54 AM
  #4  
Tech Adept
Thread Starter
iTrader: (5)
 
Join Date: Feb 2010
Posts: 189
Trader Rating: 5 (100%+)
Default

I wonder if I ask them to send me a new one if it is going to come from the US Warehouse or be put on the slowest boat they can find crossing the pacific?
BrianTx01 is offline  
Reply With Quote
Old 02-12-2015, 12:07 PM
  #5  
Tech Master
 
heretic's Avatar
 
Join Date: Aug 2006
Location: europe
Posts: 1,110
Default

Have you checked the banana plugs on the motor? A defective one might cause what you describe.
heretic is offline  
Reply With Quote
Old 02-15-2015, 08:02 AM
  #6  
Tech Adept
Thread Starter
iTrader: (5)
 
Join Date: Feb 2010
Posts: 189
Trader Rating: 5 (100%+)
Default

Originally Posted by heretic View Post
Have you checked the banana plugs on the motor? A defective one might cause what you describe.
No, I didn't do that...but I didn't notice any loose connections.

At any rate the HobbyKing RMA process was pretty painless. They had me send it back to New York and I did not have to deal with any offshore support. They had a disposition the same day they received it. Be sure and ask them to credit back your shipping costs. I did and they did so without objection.
BrianTx01 is offline  
Reply With Quote
Old 02-15-2015, 04:03 PM
  #7  
Tech Adept
iTrader: (6)
 
joe c's Avatar
 
Join Date: Oct 2011
Posts: 104
Trader Rating: 6 (100%+)
Default

Nice.
I hope the new one works out.

I just ordered one for my Dromida sc4.18.
joe c is offline  
Reply With Quote
Old 02-16-2015, 01:55 PM
  #8  
Tech Master
 
heretic's Avatar
 
Join Date: Aug 2006
Location: europe
Posts: 1,110
Default

Originally Posted by BrianTx01 View Post
No, I didn't do that...but I didn't notice any loose connections.

At any rate the HobbyKing RMA process was pretty painless. They had me send it back to New York and I did not have to deal with any offshore support. They had a disposition the same day they received it. Be sure and ask them to credit back your shipping costs. I did and they did so without objection.
Agreed, Hobbyking's customer service is good in my experience.

About the plugs, mine looked and felt just fine as well. It took some moving around of the plugs on the bench to home in on the problem. When I got rid of them (soldering) my few stuttering/ cogging issues disappeared and never came back.
heretic is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service