Mini-z MR03 won't pair

Reply

Old 04-27-2019, 02:29 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Mar 2019
Posts: 7
Default Mini-z MR03 won't pair

I purchased a MR-03 Sauber in Feb. Ive probably run it less than 10 times. The last couple times i brought it to the track, it would turn on but not be paired, and I would have to pair it. Now, it wont pair at all. Someone told me that perhaps i need to replace the board. Is there anything I should do testing wise before replacing the board? Any other tricks to get it to pair? This is the item: 32327S-B MINI-Z RWD Sauber-Mercedes C9 No. 63 LM 1989 MR-03 Readyset
acidreign is offline  
Reply With Quote
Old 04-27-2019, 03:29 PM
  #2  
EMU
Tech Fanatic
iTrader: (3)
 
EMU's Avatar
 
Join Date: Apr 2009
Location: NYC
Posts: 944
Trader Rating: 3 (100%+)
Default

Are the batteries in the transmitter fully charged? What cells are you using in the transmitter? Does the light on the transmitter come on and stay on?

I would try a radio reset, then pair again.
How can I reset the Syncro KT-531P transmitter? ? MINI-Z Info

Do you have a friend with a transmitter that you can try binding to your car and see if it holds the bind. This would give an idea of the electronics in the car or transmitter are at fault.

If the issue persists, contact Kyosho America for warranty support.
EMU is online now  
Reply With Quote
Old 04-27-2019, 08:02 PM
  #3  
Tech Rookie
Thread Starter
 
Join Date: Mar 2019
Posts: 7
Default

Originally Posted by EMU View Post
Are the batteries in the transmitter fully charged? What cells are you using in the transmitter? Does the light on the transmitter come on and stay on?

I would try a radio reset, then pair again.


Do you have a friend with a transmitter that you can try binding to your car and see if it holds the bind. This would give an idea of the electronics in the car or transmitter are at fault.

If the issue persists, contact Kyosho America for warranty support.
Thanks I will try that!!!
acidreign is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service