R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 01-16-2006, 09:03 AM   #1
Tech Rookie
 
Join Date: Dec 2005
Location: Kingsville, Ca
Posts: 12
Trader Rating: 1 (100%+)
Default BAD M8 Purchased from ebay

I just received my Airtronics M8 from ebay seller and when I turned it on it made a faint crackling noise. It seemed to work fine for a while, all functions appeared to be working normally. Now it doesn't turn on at all (no power)! I did change the batteries with a freshly charged set and still nothing.

I did turn it on for a while without the crystal in it and was wondering if that was the cause of my problems or did I just get hosed from the ebay seller?
BRADI is offline   Reply With Quote
Old 01-16-2006, 09:05 AM   #2
Tech Apprentice
 
Join Date: Dec 2005
Location: UK, stoke-on-trent
Posts: 65
Default

Thats ebay for you
ashrc18TA05 is offline   Reply With Quote
Old 01-16-2006, 09:05 AM   #3
Tech Master
 
Join Date: Dec 2004
Posts: 1,131
Default

Quote:
Originally Posted by BRADI
I just received my Airtronics M8 from ebay seller and when I turned it on it made a faint crackling noise. It seemed to work fine for a while, all functions appeared to be working normally. Now it doesn't turn on at all (no power)! I did change the batteries with a freshly charged set and still nothing.

I did turn it on for a while without the crystal in it and was wondering if that was the cause of my problems or did I just get hosed from the ebay seller?
Crystals have nothing to do with what is happening to your radio.
Juan Aveytia is offline   Reply With Quote
Old 01-16-2006, 09:24 AM   #4
Tech Master
 
Join Date: Dec 2001
Location: Arizona
Posts: 1,197
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by BRADI
I just received my Airtronics M8 from ebay seller and when I turned it on it made a faint crackling noise. It seemed to work fine for a while, all functions appeared to be working normally. Now it doesn't turn on at all (no power)! I did change the batteries with a freshly charged set and still nothing.

I did turn it on for a while without the crystal in it and was wondering if that was the cause of my problems or did I just get hosed from the ebay seller?
Call Airtronics for info, send it to them for repair, they do not charge that much and be sure to have them re-calibrate the radio as well. It will be like new.
pops is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Purchased New Setup Mrsracing Electric Off-Road 1 01-30-2008 02:38 PM
just purchased rc10gt wanting to get in to racing or playing around need help scottcop Electric Off-Road 5 01-29-2007 06:08 PM
Help! My engine won't start, I just purchased it! Honda_Civic_Si Nitro On-Road 26 12-28-2004 04:23 PM
Purchased new JR radio and.... RedScorp Nitro On-Road 3 04-04-2003 06:56 PM
Have any of you purchased from readytorunrc.com? grampi Electric Off-Road 3 12-14-2002 11:43 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:43 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net