Go Back  R/C Tech Forums > General Forums > Electric On-Road
Problems with cut off's >

Problems with cut off's

Problems with cut off's

Old 10-02-2016, 06:22 PM
  #1  
Tech Apprentice
Thread Starter
 
Join Date: Jun 2016
Posts: 87
Default Problems with cut off's

Hello, I have a GT2 with a Hobbywing Max 5 and a Cordova 2400kv. It's a new build and I can't seem to get full power. Also when I give it throttle and let off and try to give throttle again it's dead but then I pull trigger again and it will go. Same w/ braking.. Thanks
irish177 is offline  
Old 10-02-2016, 07:53 PM
  #2  
Tech Adept
iTrader: (2)
 
Join Date: Dec 2009
Location: Australia
Posts: 167
Trader Rating: 2 (100%+)
Default

Don't know what your issue may be but just check that your transmitter throttle and brake epa are set to maximum travel and that the subtrim is at neutral. Do this first!
I assume the esc would have a setup programming instructions aswell, go through that process.
That should at least set your throttle and brake correctly.
If that doesn't work maybe check sensor plugs, all connections aswell.
Hope this helps.
svturtle is offline  
Old 10-03-2016, 06:18 AM
  #3  
Tech Apprentice
Thread Starter
 
Join Date: Jun 2016
Posts: 87
Default Max 5 cutting off

Originally Posted by svturtle View Post
Don't know what your issue may be but just check that your transmitter throttle and brake epa are set to maximum travel and that the subtrim is at neutral. Do this first!
I assume the esc would have a setup programming instructions aswell, go through that process.
That should at least set your throttle and brake correctly.
If that doesn't work maybe check sensor plugs, all connections aswell.
Hope this helps.
Thanks for the help, I ran threw that list already.
irish177 is offline  
Old 10-03-2016, 10:59 AM
  #4  
Tech Adept
iTrader: (2)
 
Join Date: Dec 2009
Location: Australia
Posts: 167
Trader Rating: 2 (100%+)
Default

No probs, I'd just be swapping out stuff now in the hope of finding the issue! Hopefully someone more knowledgeable can help you out.
Good luck.
svturtle is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.