R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 07-26-2014, 02:23 AM   #1
Tech Rookie
 
Join Date: Jul 2013
Posts: 8
Exclamation Hsp Flying Fish

Hi I have a hsp flying fish ...
im having some troubles
so i plug in the battery etc etc ...
turn it on and the back wheels jump ... then it just (i guess) shuts down
I went into jaycar and they said it would be something to do with the battery( its 1 and a half years old)
Could someone please give me an answer... to how i could fix etc....
Thanks that would be amazing!
^>^>^>^>^>^>^>^>^>^>^>
Ranger7078 is offline   Reply With Quote
Old 08-01-2014, 07:07 PM   #2
Tech Addict
 
Join Date: Nov 2008
Location: NZ
Posts: 677
Default

It could be the batt , the charger,radio gear, the esc causing the problem.
They are a cheap & nasty car (I had one) , mine had an esc that was pretty bad .
1101 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:59 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net