R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 01-04-2014, 05:55 PM   #1
Tech Rookie
 
Join Date: Jan 2014
Posts: 5
Default Sanwa M11x Please Help

hi i have been using a sanwa m11x wheel radio for a while now and for some reason it has just started not to centralise the wheel properly,
and into different places and it's not because the spring tention of the wheel is too loose please help
thanks.
aceracer1 is offline   Reply With Quote
Old 01-05-2014, 11:35 AM   #2
Tech Adept
 
NItrox416's Avatar
 
Join Date: Nov 2011
Posts: 169
Default

hi, probably is not a radio issue but a servo one.
Try to put on the car another servo, new should be better, and check if work well with the m11x.
NItrox416 is offline   Reply With Quote
Old 01-05-2014, 02:46 PM   #3
Tech Rookie
 
Join Date: Jan 2014
Posts: 5
Default

it's not the servo it's the sanwa because it does it when the car is turned off when your looking at the dual rate screen it does not go back to neutral
aceracer1 is offline   Reply With Quote
Old 01-06-2014, 06:19 AM   #4
M7H
Tech Elite
 
M7H's Avatar
 
Join Date: Dec 2004
Location: The Netherlands
Posts: 2,196
Default

Maybe it is time to replace the steering potentiometer, just send it in for service to a service centre.
__________________
Serpent
M7H is offline   Reply With Quote
Old 01-06-2014, 07:50 AM   #5
Tech Regular
 
Mr. MR4's Avatar
 
Join Date: Oct 2001
Location: Malta, EU
Posts: 297
Trader Rating: 8 (100%+)
Default

I have a sanwa exzes x which needs repairs. Where can I get it repaired?
__________________
Xray T4'16 HobbyWing Xerun 120A V3.1
Xray X1'16 HobbyWing Justock
Yokomo R12C3 HobbyWing Xerun V3.1
Mr. MR4 is offline   Reply With Quote
Old 01-07-2014, 01:58 AM   #6
Tech Adept
 
Peakki's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 158
Trader Rating: 1 (100%+)
Default

You can calibrate the radio by yourself via VR ADJUST (scroll the menus and you'll find it).
There is instructions in the manual how to do it.
__________________
Destiny&V-Dezign 1:12- Sanwa M12s - Xray XB4 2016 - Xray XB2 DE - HW XR10Pro & Team Orion R10.1 Pro & Sanwa Super Vortex Zero Gen2- Team Orion Vortex & Muchmore & Reedy BL motors - Sanwa & Highest & Sav÷x servos
Peakki is offline   Reply With Quote
Old 01-13-2014, 01:49 PM   #7
Tech Rookie
 
Join Date: Jan 2014
Posts: 5
Default

already done that didn't work
aceracer1 is offline   Reply With Quote
Old 01-13-2014, 02:29 PM   #8
Tech Master
 
Geezatec's Avatar
 
Join Date: Oct 2007
Posts: 1,460
Default

How many model you have entered on your M11? One or more models have the same problem?

Default radio by Basic op display Panel, by depressing Inc & Dec at the same time. It'll reset to the original values. Then reset all Exp, EPA, Etc... Also re calibrate your TX to ESC First. For some reason it lost its setting.

Good luck!!
Geezatec is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net