R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 11-17-2013, 02:51 PM   #1
Tech Rookie
 
Join Date: Sep 2013
Location: Poland, Poznan
Posts: 2
Default 1/10 TC 17.5T + boost speedo setup

Hi everyone,
I was looking for the info about speedo setup for 17.5T boosted class 1/10 touring, few times found smthing usefull, but didn't work...

I used to driving Stock few years, but always have the same problem. The car, which is technical set-uped perfect (Xray always ) but never as fast as everyone. The problem almost gone, when i bought Tekin - RS Gen2 combo. Unfortunately polarity error and RS Gen2 is gone now...

What setup should I made? Maybe i have wrong FDR? I'm driving 1:5.42 on medium to small carpet track with medium grip. Chassis: Xray T4 2014, motor Tekin Gen2 17.5, Speedo Xerun v3 (will be gen2, soon...)

Almost standard Xerun v3 17.5 setup, 95 Celsius degrees on motor with fan and radiator...
Thanks,
Maciej
Maciej Marcinek is offline   Reply With Quote
Reply


Tags
17.5 stock, boosted, setup, stock


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net