Go Back  R/C Tech Forums > General Forums > Electric On-Road
New Novak Brusless System >

New Novak Brusless System

New Novak Brusless System

Old 04-10-2006, 07:34 PM
  #871  
Tech Regular
 
Join Date: Jul 2004
Location: Kuala Lumpur Malaysia
Posts: 278
Default

if your car slowed down instead of complete halt, your temperature sensor is screwed. Send it back to Novak and you will get a remanufactured GTB set. I bought mine brand new and after a few runs, my car slowed down. Charlie confirmed that it's because of the defective temp sensor. So Novak changed my GTB set with remanufactured one (even the heat sink has big scratches)
azmio is offline  
Old 04-10-2006, 08:25 PM
  #872  
Tech Fanatic
iTrader: (3)
 
Drewdc90's Avatar
 
Join Date: Sep 2005
Location: Sunshine Coast Australia
Posts: 828
Trader Rating: 3 (100%+)
Default

Originally Posted by AngryAsian
I don't know about a rev limit or anything.. but to answer your thermal shutdown question...

The GTB doesn't actually just die. It allows you to crawl around on part throttle(It restricts to like 1/4 throttle or less) to get you back into the pits. But the car still moves... once it cools down enough then it goes back to full power.

Have you checked the esc when this is happening? Which lights are flashing on the unit? they'll tell you whether it's a thermal situaiton or a rotor dectect situation...
Like Azmio said if your car doesn't stop completely when it thermals you need to send it back.
Drew.
Drewdc90 is offline  
Old 04-11-2006, 01:32 AM
  #873  
Tech Addict
iTrader: (4)
 
AngryAsian's Avatar
 
Join Date: Oct 2005
Location: Melbourne, Australia
Posts: 550
Trader Rating: 4 (100%+)
Default

No joke??...

Anything else i should know now that i've had the thing for...err... long enough that i forgot when i got it!!!!

Might have a crack at it again... try to thermal the unit and see if it does the same thing...

LMAO!!
AngryAsian is offline  
Old 04-11-2006, 05:17 AM
  #874  
Tech Regular
 
Join Date: Jul 2004
Location: Kuala Lumpur Malaysia
Posts: 278
Default

dude,

whatever it is, make sure you have your receipt handy. if it's still within the 120 days, you should be able to get it replaced. Dont go on using your GTB, send it back. I have tried everything i could, that damn thing still thermal shutdown even with 4 cell pan car.
azmio is offline  
Old 04-11-2006, 06:04 AM
  #875  
Tech Addict
iTrader: (4)
 
AngryAsian's Avatar
 
Join Date: Oct 2005
Location: Melbourne, Australia
Posts: 550
Trader Rating: 4 (100%+)
Default

Erhm... i suppose the reason WHY i've not ever been bothered by it, it that my unit never really thermals on me...

I temped the motor on the 38 degree day (100F)and it was reading at 76deg(169F) C. It was really freakin hot... other than that, i've not had any issues with it at all even on relatively hot days.. (around 33-34deg celcius - 93F). Even running back to back packs didn't seem to upset it.

To be honest i REALLY don't want to send it back. I'm sure it has been more than 120days and so far i've not had any issues with it. . .

Unless i'm not getting as much power as i should from it or something, then i think i'll leave it be. Don't fix what's not broken.. (Yes i do realise the terrible irony here... )

Should i be concerned that this temp probe thing also affects say the run-time/punch/speed etc??..

maybe time to mail Charlie..



**edit** had a look at last time the car thermalled (got it on Video..!!) - it does indeed STOP for a short while. But then it crawls back..... could this be because i';m just on what Novak recommends is the max temp? I suppose the motor would have been a bit hotter than that, but cooled sufficiently to regain operation?.. Dammit you guys had me scared... though it didn't really make sense to me..


so no-one can relate to the car crawling back?..



Sorry - my bad.. bad memory!..
AngryAsian is offline  
Old 04-11-2006, 07:56 AM
  #876  
Tech Fanatic
iTrader: (15)
 
Takt's Avatar
 
Join Date: Feb 2004
Location: Madison, WI
Posts: 901
Trader Rating: 15 (100%+)
Default

Thanks all --

Guess it's time to find the receipt. I have an email into Novak about it.

Thanks
Takt is offline  
Old 04-11-2006, 01:45 PM
  #877  
Tech Regular
iTrader: (9)
 
Safer SX's Avatar
 
Join Date: Jul 2005
Posts: 454
Trader Rating: 9 (100%+)
Default

Well I did a test last night with the 4.5 with the max rollout and the other chappy had a 5.5 with not quite the max rollout. I think I have wasted my money buying the 4.5 as his was slightly and I mean slightly faster in a straight line, when the cars came off the track my 4.5 you could just hang on to it as it was hot and his 5.5 was warm. I think at the end of the day Novak has taken us for a ride with their product once again.
Safer SX is offline  
Old 04-11-2006, 01:48 PM
  #878  
Super Moderator
iTrader: (213)
 
Marcos.J's Avatar
 
Join Date: Sep 2003
Location: Semper Fi
Posts: 31,066
Trader Rating: 213 (100%+)
Default

Originally Posted by Safer SX
Well I did a test last night with the 4.5 with the max rollout and the other chappy had a 5.5 with not quite the max rollout. I think I have wasted my money buying the 4.5 as his was slightly and I mean slightly faster in a straight line, when the cars came off the track my 4.5 you could just hang on to it as it was hot and his 5.5 was warm. I think at the end of the day Novak has taken us for a ride with their product once again.
Im very happy with the 4.5 ,if you dont want it Ill take it of your hands I can always use a second motor
Marcos.J is offline  
Old 04-11-2006, 03:38 PM
  #879  
Tech Lord
iTrader: (13)
 
protc3's Avatar
 
Join Date: Jun 2003
Location: Spring Hill,Florida
Posts: 10,867
Trader Rating: 13 (100%+)
Default

Originally Posted by Safer SX
Well I did a test last night with the 4.5 with the max rollout and the other chappy had a 5.5 with not quite the max rollout. I think I have wasted my money buying the 4.5 as his was slightly and I mean slightly faster in a straight line, when the cars came off the track my 4.5 you could just hang on to it as it was hot and his 5.5 was warm. I think at the end of the day Novak has taken us for a ride with their product once again.
i would double check your setup on the speedo.the 4.5 i ran was insane fast.it was just as if not faster than my checkpoint 7x1 ultralight.
protc3 is offline  
Old 04-11-2006, 04:11 PM
  #880  
Tech Fanatic
iTrader: (3)
 
Drewdc90's Avatar
 
Join Date: Sep 2005
Location: Sunshine Coast Australia
Posts: 828
Trader Rating: 3 (100%+)
Default

Originally Posted by AngryAsian
Erhm... i suppose the reason WHY i've not ever been bothered by it, it that my unit never really thermals on me...

I temped the motor on the 38 degree day (100F)and it was reading at 76deg(169F) C. It was really freakin hot... other than that, i've not had any issues with it at all even on relatively hot days.. (around 33-34deg celcius - 93F). Even running back to back packs didn't seem to upset it.

To be honest i REALLY don't want to send it back. I'm sure it has been more than 120days and so far i've not had any issues with it. . .

Unless i'm not getting as much power as i should from it or something, then i think i'll leave it be. Don't fix what's not broken.. (Yes i do realise the terrible irony here... )

Should i be concerned that this temp probe thing also affects say the run-time/punch/speed etc??..

maybe time to mail Charlie..



**edit** had a look at last time the car thermalled (got it on Video..!!) - it does indeed STOP for a short while. But then it crawls back..... could this be because i';m just on what Novak recommends is the max temp? I suppose the motor would have been a bit hotter than that, but cooled sufficiently to regain operation?.. Dammit you guys had me scared... though it didn't really make sense to me..


so no-one can relate to the car crawling back?..



Sorry - my bad.. bad memory!..
I don't know if it will or won't be affecting speed or punch. When I sent mine back they told me it was a problem with one of the fets aswell as the temp sensor. The replacment they sent out was actually faster than my original one.
Drew.
Drewdc90 is offline  
Old 04-11-2006, 04:44 PM
  #881  
The Evicerator
 
Join Date: Sep 2001
Location: Scottsdale, AZ
Posts: 4,145
Default

What was your rollout/gear ratio?

Originally Posted by Safer SX
Well I did a test last night with the 4.5 with the max rollout and the other chappy had a 5.5 with not quite the max rollout. I think I have wasted my money buying the 4.5 as his was slightly and I mean slightly faster in a straight line, when the cars came off the track my 4.5 you could just hang on to it as it was hot and his 5.5 was warm. I think at the end of the day Novak has taken us for a ride with their product once again.
Steve Weiss is offline  
Old 04-11-2006, 07:56 PM
  #882  
Tech Regular
iTrader: (8)
 
Join Date: May 2002
Location: Piqua, Ohio
Posts: 293
Trader Rating: 8 (100%+)
Default

where did you guys get your 4.5 gtb systems from? can't find any shops with them available yet?
racerfreedxxxs is offline  
Old 04-11-2006, 08:02 PM
  #883  
Tech Regular
iTrader: (1)
 
Join Date: Nov 2005
Location: Alexandria Virginia
Posts: 260
Trader Rating: 1 (100%+)
Default

You can order direct from NOVAK online!!
MOJO is offline  
Old 04-11-2006, 08:06 PM
  #884  
Tech Fanatic
 
Nexus Racing's Avatar
 
Join Date: May 2005
Posts: 848
Default

Originally Posted by racerfreedxxxs
where did you guys get your 4.5 gtb systems from? can't find any shops with them available yet?
Got mine by backordering through Great Planes...I think Great Planes gets them pretty often, but has so many backorders that they still show "out of stock".
Nexus Racing is offline  
Old 04-11-2006, 08:07 PM
  #885  
Tech Regular
iTrader: (8)
 
Join Date: May 2002
Location: Piqua, Ohio
Posts: 293
Trader Rating: 8 (100%+)
Default

thanks
racerfreedxxxs is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.