R/C Tech Forums

R/C Tech Forums (https://www.rctech.net/forum/)
-   Electric On-Road (https://www.rctech.net/forum/electric-road-2/)
-   -   Speed Passion F1 car - The SP1 (https://www.rctech.net/forum/electric-road/712987-speed-passion-f1-car-sp1.html)

Sonter 11-17-2013 09:56 PM

Hello guys,

Unfortunately I couldn't even start racing yesterday as a guy slightly hit one of my rear wheels and I had broblem with my axle immediately. Seems that the axle is very week and I got a little disappointed about this. Are there any upgrades I should do, to not have this problems next time? Some of the other guys rolled their cars very hard and nothing happened to thir car ! Did someone else had the same issue?

metalnut 11-17-2013 10:25 PM


Originally Posted by Sonter (Post 12734405)
Hello guys,

Unfortunately I couldn't even start racing yesterday as a guy slightly hit one of my rear wheels and I had broblem with my axle immediately. Seems that the axle is very week and I got a little disappointed about this. Are there any upgrades I should do, to not have this problems next time? Some of the other guys rolled their cars very hard and nothing happened to thir car ! Did someone else had the same issue?

First, please decrease your font size, you almost gave me a heart attack.

Second, my car has traction rolled a number of times and got hit pretty damn hard on the straight (breaking a lot of stuff), but my axle is still fine. Seems very sturdy to me. What exactly went wrong with yours?

Sonter 11-17-2013 11:18 PM


Originally Posted by metalnut (Post 12734452)
First, please decrease your font size, you almost gave me a heart attack.

Second, my car has traction rolled a number of times and got hit pretty damn hard on the straight (breaking a lot of stuff), but my axle is still fine. Seems very sturdy to me. What exactly went wrong with yours?

Sorry about the font size... Sent it from my mobile and tought that my font was too small.

My rear axle was bent really badly after a small hit on the rear wheel by an other car. Actually the car didn't roll after the hit but the rear axle came like a banana. It was not a big hit... And I got disappointed because of this issue. Could the material of the rear axle was defected? Since you are saying that you hit the car hard and nothing happened to the rear axle!

InspGadgt 11-17-2013 11:21 PM

I've put mine through the ringer and not bent the rear axle. Maybe you got one with a weak spot or something.

metalnut 11-17-2013 11:45 PM


Originally Posted by Sonter (Post 12734521)
Sorry about the font size... Sent it from my mobile and tought that my font was too small.

My rear axle was bent really badly after a small hit on the rear wheel by an other car. Actually the car didn't roll after the hit but the rear axle came like a banana. It was not a big hit... And I got disappointed because of this issue. Could the material of the rear axle was defected? Since you are saying that you hit the car hard and nothing happened to the rear axle!

I remember someone earlier in this thread reporting the same issue, but I think most of us have not had this problem. Weird. Maybe it was indeed a bad batch, or some unnoticed QA issue? I would ping Solara here, maybe take a few pictures, and see if he can help you.

Sonter 11-18-2013 12:01 AM


Originally Posted by metalnut (Post 12734550)
I remember someone earlier in this thread reporting the same issue, but I think most of us have not had this problem. Weird. Maybe it was indeed a bad batch, or some unnoticed QA issue? I would ping Solara here, maybe take a few pictures, and see if he can help you.

It would be great to get some help from Solara cause I didn't do one lap with the car yet and already with an issue! I will upload a video on YouTube and link it here soon to show the rear axle issue.
:(

Sonter 11-18-2013 01:19 AM

Here is the link on youtube to see me rear axle after a small hit by another car on the rear tire.

http://www.youtube.com/watch?v=LmnDVl8gcus

:cry:

InspGadgt 11-18-2013 09:04 AM

The vid is set as private

Sonter 11-18-2013 09:21 AM


Originally Posted by InspGadgt (Post 12735469)
The vid is set as private

Not any more. You can watch it

Solara 11-18-2013 09:50 AM


Originally Posted by Sonter (Post 12735525)
Not any more. You can watch it

Got it...please check your PM. And yes, this is the 1st bent metal axle that I have seen for SP1. My car has easily 70-80 packs thru and I have hit by 1/8th ON ROAD on my F1 car before.......still using the prototype axle like 8 months ago. Were you hit by a SUV on the track....? (Just kidding..)

Sonter 11-18-2013 09:57 AM


Originally Posted by Solara (Post 12735610)
Got it...please check your PM. And yes, this is the 1st bent metal axle that I have seen for SP1. My car has easily 70-80 packs thru and I have hit by 1/8th ON ROAD on my F1 car before.......still using the prototype axle like 8 months ago. Were you hit by a SUV on the track....? (Just kidding..)

I was hit by an ARC Formula 1 car. Maybe an SUV wouldn't have made that damage on my SP-1 :ha::ha:

I have PM you back!!

busman 11-18-2013 10:00 AM

Iwas nailed at My first race, sheared off My axle, didn't hurt anything else.

Bought a new one and no problems since..

Sonter 11-18-2013 10:38 AM

Yesterday at the races I noticed that the Ride super soft tires has an issue. After each race they where glueing the tire with the rim cause it gets thorn out. Seem like the rubber cracks. Have anyone ever noticed this ?
What tires do you suggest instead of the Ride super soft? something with the same compound !

British Menace 11-18-2013 11:17 AM

Sorry .... not wanting to hyjack the thread but need a little help painting my F1.

What paint most closely resembles the red in Redbulls F1 Red ..... rattlecan that is?

Thanks for your help.

Regards
BM

Ph3nyx 11-18-2013 11:36 AM


Originally Posted by Sonter (Post 12735747)
Yesterday at the races I noticed that the Ride super soft tires has an issue. After each race they where glueing the tire with the rim cause it gets thorn out. Seem like the rubber cracks. Have anyone ever noticed this ?
What tires do you suggest instead of the Ride super soft? something with the same compound !

it's a known issue with the ride , you'll have to use CA right out of the box before the 1rst run (and a good one).
i'll prefere by far using pit shimizu 571/572 or 574/575 for carpet.


All times are GMT -7. It is currently 11:51 AM.

Powered By: vBulletin v3.9.3.6
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.