R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 03-21-2008, 11:30 PM   #1426
Tech Elite
 
stulec52's Avatar
 
Join Date: May 2002
Location: Calgary
Posts: 3,181
Trader Rating: 26 (100%+)
Send a message via ICQ to stulec52 Send a message via AIM to stulec52
Default

Hi all,

Just have a question about my ICC.
Since doing the last update my charger now beeps quite a bit during charge and discharge and at the same time saying error and usually cell 3 or 4.
it then stops beeping and carries on charging or discharging, and still seems to work perfectly other than the annoying beeping.

Anyone else had this?
any suggestions as to what to do, or maybe that's just the way it is?

Thanks
Stu
__________________
www.pmhobbycraft.ca/store/
www.tamiyaclub.com/
stulec52 is offline   Reply With Quote
Old 03-22-2008, 02:45 AM   #1427
Tech Elite
 
Taz_S's Avatar
 
Join Date: Aug 2001
Location: Santa Rosa CA
Posts: 2,584
Trader Rating: 5 (100%+)
Default

that all i need now is them to get it lipo update.
Taz_S is offline   Reply With Quote
Old 03-22-2008, 04:36 AM   #1428
Tech Master
 
Join Date: Mar 2004
Location: Earth
Posts: 1,039
Send a message via ICQ to rcnewb2004
Default

i have checked their website once a day at least for the past 3 years... and since june... no update...
__________________
Ta04-TRF, EVO 5
Futaba
KO Propo
Spintec
rcnewb2004 is offline   Reply With Quote
Old 03-22-2008, 12:54 PM   #1429
Tech Adept
 
bs6ef's Avatar
 
Join Date: Sep 2006
Location: England
Posts: 236
Default

Wow i was gonna buy an ICC this week, but after reading all of your comments on how c**p spintec are with there customer service and also the problems you guys have been having with there products, it has helped me make up my mind.

steve
bs6ef is offline   Reply With Quote
Old 03-22-2008, 01:17 PM   #1430
Tech Rookie
 
Join Date: Apr 2006
Posts: 13
Default

Customer service of Spintec is 100% fine, best in the industry. It is just that they are a small company and slow with the new lipo software, but that should be available soon as well. Also the latest version (hardware 1.6) of the ICC performs really well, it now has 2 cooling fans, extra cooling ducts in the side and more and improved spring contacts.

I know Erik always answers his email and will do all he can to help everybody out. He just does not have enough time to be present on all these forums, so you can't blame him that he is not on here to answer.

Just my 2 cents
aston is offline   Reply With Quote
Old 03-27-2008, 06:10 AM   #1431
djw
Tech Rookie
 
Join Date: Mar 2007
Posts: 10
Default

Quote:
Originally Posted by aston View Post
Customer service of Spintec is 100% fine, best in the industry. It is just that they are a small company and slow with the new lipo software, but that should be available soon as well. Also the latest version (hardware 1.6) of the ICC performs really well, it now has 2 cooling fans, extra cooling ducts in the side and more and improved spring contacts.

I know Erik always answers his email and will do all he can to help everybody out. He just does not have enough time to be present on all these forums, so you can't blame him that he is not on here to answer.

Just my 2 cents
Hi Aston, where did you get this info on 1.6 hardware version? there is no such thing on spintec.nl ....
djw is offline   Reply With Quote
Old 03-27-2008, 06:39 AM   #1432
Tech Master
 
billjacobs's Avatar
 
Join Date: Sep 2004
Location: Rockville, MD
Posts: 1,264
Trader Rating: 54 (100%+)
Default version 1.6

He also dreamed of the lipo update in version 1.6. All of the improvements are great- if true, why did it take so long? Unfortunately, with me and many other racers, spintec has lost their market.
billjacobs is offline   Reply With Quote
Old 03-27-2008, 08:50 AM   #1433
Tech Addict
 
Join Date: Dec 2005
Location: Belgium
Posts: 528
Trader Rating: 6 (100%+)
Default

A quick word of advice, if you're 100% sure of correct battery placement and that your batteries are in TipTop condition. You know the cell contact is good and the charger say while checking before it really starts charging:

"Voltage error, continue if sure"

DO NOT PUSH CONTINUE, I did this and smoked yet another set of FETs so the charger has been sent to spintec again.

While doing this I also mailed Erik told him this and asked about the LIPO update, he said the software is ready and they're testing it for reliability atm. so lets hope it wont be long till it gets here...
__________________
Make it idiot-proof, and someone will make a better idiot.
Quante is offline   Reply With Quote
Old 03-27-2008, 10:38 AM   #1434
Tech Elite
 
stulec52's Avatar
 
Join Date: May 2002
Location: Calgary
Posts: 3,181
Trader Rating: 26 (100%+)
Send a message via ICQ to stulec52 Send a message via AIM to stulec52
Default

Quote:
Originally Posted by stulec52 View Post
Hi all,

Just have a question about my ICC.
Since doing the last update my charger now beeps quite a bit during charge and discharge and at the same time saying error and usually cell 3 or 4.
it then stops beeping and carries on charging or discharging, and still seems to work perfectly other than the annoying beeping.

Anyone else had this?
any suggestions as to what to do, or maybe that's just the way it is?

Thanks
Stu
I have also seen error 1+ too?
anyone else getting this?
Erik did reply to me, but didn't know what to make of this.
__________________
www.pmhobbycraft.ca/store/
www.tamiyaclub.com/
stulec52 is offline   Reply With Quote
Old 03-27-2008, 11:06 AM   #1435
Tech Master
 
Join Date: Mar 2004
Location: Earth
Posts: 1,039
Send a message via ICQ to rcnewb2004
Default

If I remember right, Error 1+ (means there is one or more cells that have problems)... adjust all the contacts, once you have adjusted all the contacts... then things should be fixed.
__________________
Ta04-TRF, EVO 5
Futaba
KO Propo
Spintec
rcnewb2004 is offline   Reply With Quote
Old 03-27-2008, 03:07 PM   #1436
Tech Adept
 
Join Date: Jul 2006
Posts: 133
Default

I'll be getting the latest hardware revision straight from my spintec supplier, i'm guessing Spintec have been updating the hardware to make it more reliable, it has apparently shipped, so it should be here any day
__________________
Matt van der Haas
RCRacer.co.nz - New Zealand RC - news - videos - photos
drivingpro is offline   Reply With Quote
Old 05-05-2008, 08:48 AM   #1437
Tech Apprentice
 
shy@klp.no's Avatar
 
Join Date: Jun 2005
Location: Norway
Posts: 51
Trader Rating: 1 (100%+)
Default

Any news?

Still no new version to download on www.spintec.nl

My problems have been:
-contact problems, takes a lot of cleaning/adjusting to make it run
-low voltage error, should have been possible to "force" it to charge. I must sometimes charge it a bit on the external or another charger first in order to make it run
-my external charger overcharged a pack. After that it will not run, does not display mAh count

I really like the concept, so I hope they can refine it...
__________________
Life's too short to go slow! www.ymr.no
shy@klp.no is offline   Reply With Quote
Old 05-05-2008, 09:12 AM   #1438
Tech Master
 
Join Date: Mar 2004
Location: Earth
Posts: 1,039
Send a message via ICQ to rcnewb2004
Default

The last thing i saw on this thread was that they are testing the new version, which should include a lipo charging feature.

In the last version, the low voltage error should be corrected. You can force charge it, even if there is a low voltage error in the battery slot.

The external leads should never be used... I think the general consensus is that it sucks and it has no overload protection, so you can fry the external leads if you are not careful.

With regards to the cleaning and adjusting... make sure your batteries are all made using a jig, clean the probes regularly, and the bars regularly... and there shouldn't be too much of a problem...

I hope they will come up with a new update too. Notice their updates are appearing slower and slower...
__________________
Ta04-TRF, EVO 5
Futaba
KO Propo
Spintec
rcnewb2004 is offline   Reply With Quote
Old 05-06-2008, 11:40 PM   #1439
Tech Adept
 
Join Date: Oct 2001
Location: Auckland, New Zealand
Posts: 148
Send a message via ICQ to Seano
Default

Quote:
Originally Posted by rcnewb2004 View Post
The external leads should never be used... I think the general consensus is that it sucks and it has no overload protection, so you can fry the external leads if you are not careful.
Wouldn't they be used for Lipo charging? Sounds dangerous.
Seano is offline   Reply With Quote
Old 05-07-2008, 12:43 AM   #1440
Tech Adept
 
Join Date: Jul 2006
Posts: 133
Default

I just recently got the 1.6 hardware version with 1.7B firmware.

Man this thing is awesome.

Charging in the tray while using my comm lathe is awesome
__________________
Matt van der Haas
RCRacer.co.nz - New Zealand RC - news - videos - photos
drivingpro is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spintec ICC Charger MDawson R/C Items: For Sale/Trade 1 01-29-2008 09:05 AM
Spintec ICC charger ioxqq R/C Items: For Sale/Trade 2 07-15-2007 10:53 AM
Spintec ICC charger Dusty Kemp R/C Items: For Sale/Trade 1 10-27-2006 06:33 AM
Spintec Charger Nuno Gancho Electric On-Road 3 07-21-2006 04:32 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:56 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net