spintec I.C.C charger

You're on Page 69 of 102
Go to
  • Quote:
    - 5 cell option added (note: this also requires hardware update kit for
    hardwareversions 1.4 and lower!)
    Question.. how do you tell hardware vesrion??? Must open ICC case?

    edit: typo
  • no need to open case, it should be in system info
  • I have just noticed something using firmware v 1.06c for a few minutes
    If you change between the charge settings (IB4200, GP3700 etc) It doesn't remember to discharge before charge.

    Also can someone tell me how often and how long after peaking will the Autorepeak occur
  • Hardware update
    Does anyone know what parts are involved in the hardware update?

    I found using the new firmware update that the temp readings have possibly gone the other way, lower readings than my temp gun never a worry about capacity either putting 5200mah+ into 4200s on 1mv setting.
    Allthough I only ever had any problems if the packs had suspect cell/s they would heat up.
  • what do you mean the temp readings have gone the other way? (for me, the temp readings on a temp gun has ALWAYS been lower than that of the temp readings of the icc)

    i think rob said a few posts ago:
    it's very simple, just 3 connecters, takes about a few seconds.
    And don't forget to change the settings between 5 and 6.

    but i am eager to see when it will hit the market too..
  • Unregistered:

    Hi,

    I have just gotten a Spintec I.I.C. and it has the 1.06 update. have you had any problems like you discribed while charging 6 cells?? (I just got it and have yet to hook it up ot a P.S.) also do you have the P,C, cable????
    Thanks
  • [QUOTE=rcnewb2004]what do you mean the temp readings have gone the other way? (for me, the temp readings on a temp gun has ALWAYS been lower than that of the temp readings of the icc)

    They seem to be the other way ie cells read cooler with the temp gun than what it says on the charger display.
    I have always just set the mv to keep the cells cooler no other charger puts in as much mah as the icc and I have a few top line chargers.
    The other thing I have done is used the older muchmore battery heatsink with the top removed placed on top of the cells to reduce heat, this works very well as sometimes it gets to 40 deg celsius here.
  • bjspinner,

    its good to know that the temperature on the icc is reading higher than the temp gun... at least for me, since i have always went by the numbers on the temp gun.

    just wondering though, you said the icc can put more juice in.... have you tried discharge and see if it can take more juice out? (just a curious newb here hehe)
  • Quote: Unregistered:

    Hi,

    I have just gotten a Spintec I.I.C. and it has the 1.06 update. have you had any problems like you discribed while charging 6 cells?? (I just got it and have yet to hook it up ot a P.S.) also do you have the P,C, cable????
    Thanks
    Actually, I've never charged a 6 cell pack with the new software. I would assume that it's the same problems.

    It was 22C at the track last night and it's not very easy to get the cells up to 31.5 before they peak if you're charging very hard. I leave a bunch of runtime in the pack and discharge it right before I charge and that works pretty well.

    Still need to get the cable.
  • I noticed the temp thing myself last night. They were reading 50 degrees C when they were discharging and the temp gun said 40. Kind of worried me that they won't get fully charged now and they might shut-off with the temp if they are reading higher now.... I still need to charge a pack on it though to check. I thought it was a little weird, the temps being backwards now.
  • just wondering though, you said the icc can put more juice in.... have you tried discharge and see if it can take more juice out? (just a curious newb here hehe)[/QUOTE]

    That is the big question.

    Only about another 50-70mah but there is a more noticable increase in voltage and punch.
  • cool! i cannot wait to get home... (in 7 months) and use the icc again... dang i miss this hobby.... >_<

    The difference is by 10 degrees? ... but I would rather not get full cells than venting cells... hm.. set the temp settings 5 degrees higher?

    just guessing a solution...
  • Yes, I increased the setting from 40*c to 45*c with 1.06c. I'll try a little higher. One thing that happens now is that cells 1, 2, and 3 ALWAYS reach temperature earlier than the others, when previously it varied. Anyone else notice this?
  • is it like that with ALL your packs? or just that one specific pack?
  • All of them. I have three each of 4200, 3800, and 3700. However, the actual performance of all "seems" better than before.

Similar Threads