spintec I.C.C charger

You're on Page 51 of 102
Go to
  • The Battery Manager v2 does 35aMp.
    You don't need a egualizer because the ICC equalize the cells.
    So I discharge my packs at the Bat. Man. v2 and charge them on the ICC.

    Rob.
  • are the bat. man v2 out yet to public I want one if so where?
  • Quote: are the bat. man v2 out yet to public I want one if so where?
    In the Netherlands it's allready for sale in the shops.

    Rob.
  • Quote: are the bat. man v2 out yet to public I want one if so where?
    They are on Ebay for sale. Ive seen several of them there.

    So far the testing I have seen with the new V2 is very good. Its brought my older packs back to life a little. Small increase in runtime, good increase in voltage and large decreases in IR's.

    Still testing it on newer cells. Have not seen any Ill affects by using it so far. Batteries seem to be staying consistant.

    EA
  • I noticed huge increase in IR as well... (just using BM v1.) but i don't understand how that and better average voltage work together... i got more resistancve... but packs are performing better
  • Having spoken to my local model shop about when they are getting the Spintec ICC in stock, they again said they didn't know when, as the distributor apparently 'had had some issue's/problems with it'

    Does this ring any bells or are they making excuses?

    Skiddins
  • OK So its not just us Aussies getting shafted then?? I have tried to contact the supplier over here both by email and phone... well phone no longer connected and no response to my emails in over 4 weeks... Whats going on???
  • Checked with the my distributor here in the states and they are available.

    look here
  • I'm a bit concerned with my ICC, a lot of people locally are finding that IB4200's tend to vent (ie pop the top while charging and piss acid, bye bye cell) usually as they have external chargers, it makes a mess of the desk and costs a cell, but I had one vent inside the ICC, and it left a nasty mark, while everything still works, am I risking my charger every time I am charging a pack, particularly a IB4200? Will Spintec warrant it, and I mean Spintec themselves, because if anyone has tried to contact the Australian Spintec/SMC agent, he's been awol for the past 2 months (professionalism people!)

    I don't believe I am charging them wrong, 6 amps, 1mv and 45 degree temp cut off is conservative if anything!

    Ideas?
  • I charge mine at 5aMp, 40c cut off and 2.0mV.

    Maybe this helps,

    Rob Janssen
  • I've seen leaking IB4200's as well. Both ICC charged as regular chargers. In both cases they used 6 Amps.

    I've always charged at 5.5A and since I've seen this I've gone back to 5.0A just to be sure. I never had a problem so I don't know if it is abused cells, high charging current or a faulty batch. But I have the impression that being carefull with your packs pays off.

    I've also seen some guys using external fans to keep the pack extra cool. The bonus is it also accepts more charge. The drawback????
  • I have never used a fan and am a newb...

    but I can imagine the draw back of charging with a fan is:
    the core temp will rise after the fans are removed, this could damage the cells. Although it may take a battery longer to peak, it doesn't mean it has actually "accepted more charge".
  • Quote: I've also seen some guys using external fans to keep the pack extra cool. The bonus is it also accepts more charge. The drawback????
    Big No No....This will cause you to get a poor charge and could actually cause the cell to vent worse. If you dont believe it try cycling a pack on a GFX wiht out a fan and then try it with a fan on it....With the fan the pack will be horrible.

    EA
  • I never charge wuith a fan, big no no!

    Has anyone ever had an ICC crash, and go all blank screen on them. Has done it twice today, not cool!

    Also the hype was all this computer interface etc, yet I aint seen a software update for the ICC in ages, are we going to see some decent functionality soon?

    Right now I have a decent charger, yes, a lousy discharger, no lipo function, a Computer port that appears to be for show, so much potential so under utilised.
  • Never had a freeze in normal use.

    But once on a power dip it did freeze up. But that's normal I guess.

    Any chance of power problems?

Similar Threads