Go Back  R/C Tech Forums > General Forums > Electric On-Road
Kyosho Inferno GT2 VE - LED blink twice, Help!!! >

Kyosho Inferno GT2 VE - LED blink twice, Help!!!

Kyosho Inferno GT2 VE - LED blink twice, Help!!!

Old 11-09-2012, 11:31 AM
  #1  
Tech Rookie
Thread Starter
iTrader: (1)
 
Join Date: Sep 2012
Posts: 8
Trader Rating: 1 (100%+)
Default Kyosho Inferno GT2 VE - LED blink twice, Help!!!

I don't know if this is the right place to post this, I have Kyosho Inferno GT2 RS VE. It is having problem after I change battery.

The Green LED continuously blinking twice on the ESC when power on. There is no more throttle movement and only servo movement now. This happen After change battery to 3S 4000mah.

I know the ESC is Team Orion.

Hopefully someone could help me out. Thanks!!

Last edited by nanonstx; 11-09-2012 at 11:49 AM.
nanonstx is offline  
Old 11-09-2012, 05:51 PM
  #2  
Tech Rookie
Thread Starter
iTrader: (1)
 
Join Date: Sep 2012
Posts: 8
Trader Rating: 1 (100%+)
Default

I think is the problem is the batteries. I have a dumb question for the Inferno GT2 VE owner. Could I use 2 lipo batteries? Or I could only use one for 3s lipo battery. I was using 2 NiMH batteries when I run the car. The NiMH was fine, after I change to 2 lipo 3s there is the problem. Anyone could help? Thanks!!
nanonstx is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.