Xray T4 '13


Old 05-08-2013, 07:30 PM
  #3481  
Dan
Tech Elite
iTrader: (52)
 
Dan's Avatar
 
Join Date: Oct 2001
Posts: 4,573
Trader Rating: 52 (100%+)
Default

I knew it! LOL
Dan is offline  
Reply With Quote
Old 05-08-2013, 10:37 PM
  #3482  
Tech Lord
iTrader: (32)
 
syndr0me's Avatar
 
Join Date: Dec 2004
Location: 5280 Raceway
Posts: 13,189
Trader Rating: 32 (100%+)
Default

Any idea what might cause the right front of the car to be tweaked? I've tried loosening everything on the chassis, rebuilding shocks, etc. It's off by a good bit, yet the rear tweaks out fine.
syndr0me is offline  
Reply With Quote
Old 05-09-2013, 12:13 AM
  #3483  
Tech Elite
iTrader: (15)
 
defcone's Avatar
 
Join Date: Feb 2009
Location: Sydney
Posts: 2,349
Trader Rating: 15 (100%+)
Default

Originally Posted by syndr0me View Post
Any idea what might cause the right front of the car to be tweaked? I've tried loosening everything on the chassis, rebuilding shocks, etc. It's off by a good bit, yet the rear tweaks out fine.
Cracked bottom/top deck, bent bulkheads
defcone is offline  
Reply With Quote
Old 05-09-2013, 01:07 AM
  #3484  
Tech Regular
 
scoyle's Avatar
 
Join Date: Jan 2004
Location: Northern Ireland
Posts: 465
Default

Originally Posted by defcone View Post
Cracked bottom/top deck, bent bulkheads
If loosening off all screws including the shock tower screws, top deck and bulkhead screws does not sort it then I would agree with defcone and check the bulkheads to see if they are bent. The only way I have been able to do this in the past was to strip the car down and put each piece of alloy on a flat glass surface and see if it's bent. I have not had this happen with the Xray but did have it happen once with a TC6.

As a side note, when you are tightening up the screws I have found it useful to have a long iron bar that I put across the two shock towers and push down while I tighten each of the top deck screws.
scoyle is offline  
Reply With Quote
Old 05-09-2013, 02:53 AM
  #3485  
Tech Initiate
 
G-kenny's Avatar
 
Join Date: Nov 2006
Posts: 44
Default

Originally Posted by scoyle View Post
I have not had this happen with the Xray but did have it happen once with a TC6.
That's because you have yet to actually run the Xray
G-kenny is offline  
Reply With Quote
Old 05-09-2013, 03:21 AM
  #3486  
Tech Master
iTrader: (17)
 
Join Date: Jul 2008
Location: Hobart TAS Australia
Posts: 1,053
Trader Rating: 17 (100%+)
Default

Originally Posted by syndr0me View Post
Any idea what might cause the right front of the car to be tweaked? I've tried loosening everything on the chassis, rebuilding shocks, etc. It's off by a good bit, yet the rear tweaks out fine.
Maybe a bent hinge pin?
lethallee69 is offline  
Reply With Quote
Old 05-09-2013, 05:38 AM
  #3487  
Tech Apprentice
 
Join Date: Nov 2010
Location: suffolk uk
Posts: 62
Default tweak

Originally Posted by syndr0me View Post
Any idea what might cause the right front of the car to be tweaked? I've tried loosening everything on the chassis, rebuilding shocks, etc. It's off by a good bit, yet the rear tweaks out fine.
I have found that sometime you can tweak the chassis between the front rear arm holder and the front of the chassis, usually the right hand side from clipping track markings. undo the hangers from the arms then check to make sure the chassis is flat, then re-tighten.

also when the you have the chassis sitting flat press your thumb down in the centre of the shock tower and undo the four screws then re-tighten.

make sure that screws on the chassis are sitting flush.
matt prigmore is offline  
Reply With Quote
Old 05-09-2013, 08:47 AM
  #3488  
Tech Lord
iTrader: (32)
 
syndr0me's Avatar
 
Join Date: Dec 2004
Location: 5280 Raceway
Posts: 13,189
Trader Rating: 32 (100%+)
Default

Thanks for the input guys, I'll tear down the front and make sure everything is perfectly flat. This particular car had a few spectacular crashes at carpet nats clipping sweeper on with the right front, so it's possible something isn't straight.
syndr0me is offline  
Reply With Quote
Old 05-09-2013, 10:23 AM
  #3489  
Tech Regular
 
clparsons123's Avatar
 
Join Date: Jul 2009
Posts: 323
Default

hello everyone! well finally since nationals i have had time to look at my car and write the setup down that i won with in 13.5 touring . i ran the same car in 17.5 so it will work good with class also . i wound up finishing 5th overall in 17.5 because of bad luck in the mains . anyway here is the link to the setup (http://forum.teamxray.com/xform/inde...D=365&setup=t4)

if you have any questions just ask

thanks

Cory Parsons
clparsons123 is offline  
Reply With Quote
Old 05-09-2013, 11:05 AM
  #3490  
Tech Elite
iTrader: (70)
 
TT_Vert's Avatar
 
Join Date: Dec 2003
Location: Streamwood, IL.
Posts: 3,993
Trader Rating: 70 (100%+)
Default

I'm sure this has been answered but I'm not finding it. I want to purchase spare rear arms but the kit part # shows 303163 yet it shows 3 sway bar mounts. However it only has a 2 sway bar mounts according to my part # lookup. The arms I have are the Hard arm and I "think" the P/N is 303167. My question is, is 303167 in fact the Hard arm or is this a different material and is this in fact the kit rear arm?

Thanks
TT_Vert is offline  
Reply With Quote
Old 05-09-2013, 02:11 PM
  #3491  
Tech Elite
 
Skiddins's Avatar
 
Join Date: Feb 2006
Location: Windsor, UK
Posts: 4,820
Default

Originally Posted by TT_Vert View Post
I'm sure this has been answered but I'm not finding it. I want to purchase spare rear arms but the kit part # shows 303163 yet it shows 3 sway bar mounts. However it only has a 2 sway bar mounts according to my part # lookup. The arms I have are the Hard arm and I "think" the P/N is 303167. My question is, is 303167 in fact the Hard arm or is this a different material and is this in fact the kit rear arm?

Thanks
I think the pictures are just for reference. Just order the right part number.

Skiddins
Skiddins is offline  
Reply With Quote
Old 05-09-2013, 03:22 PM
  #3492  
Tech Regular
iTrader: (36)
 
rcguyfpr's Avatar
 
Join Date: Oct 2011
Posts: 375
Trader Rating: 36 (100%+)
Default

Question about the anti-roll bar. No matter what I do to the mounting set screws or adjusting the set screws by the end of the bar, left and right just have uneven reaction. All arms go up&down freely. However, when lift up left, right will come up; but life up right, left only moves a little (shocks off).

Front 1.4 and rear 1.2 bar, similar case. How do I fix it? thanks!
rcguyfpr is offline  
Reply With Quote
Old 05-09-2013, 03:25 PM
  #3493  
Tech Elite
iTrader: (53)
 
IIGQ4U's Avatar
 
Join Date: Dec 2005
Location: La Jolla, Palo Alto
Posts: 2,490
Trader Rating: 53 (100%+)
Default

Raise or lower the ball cups that support the anti roll bar.

Raise or lower one side by turning the ball cups until both sides react simultaneously.
IIGQ4U is offline  
Reply With Quote
Old 05-09-2013, 04:57 PM
  #3494  
Tech Elite
 
Skiddins's Avatar
 
Join Date: Feb 2006
Location: Windsor, UK
Posts: 4,820
Default

Originally Posted by rcguyfpr View Post
Question about the anti-roll bar. No matter what I do to the mounting set screws or adjusting the set screws by the end of the bar, left and right just have uneven reaction. All arms go up&down freely. However, when lift up left, right will come up; but life up right, left only moves a little (shocks off).

Front 1.4 and rear 1.2 bar, similar case. How do I fix it? thanks!
Also, put the roll bars on a flat surface like a piece of glass and check that they are flat and not twisted.
Skiddins is offline  
Reply With Quote
Old 05-09-2013, 05:15 PM
  #3495  
Tech Master
iTrader: (21)
 
dontfeelcold's Avatar
 
Join Date: Aug 2003
Location: Where there's smoke there's a tyre
Posts: 1,725
Trader Rating: 21 (100%+)
Default

The tiniest tweak in the bar can throw it out alot on the car.
dontfeelcold is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service