Go Back  R/C Tech Forums > General Forums > Electric On-Road
YOKOMO Touring Car BD-7 >

YOKOMO Touring Car BD-7

Like Tree7Likes

YOKOMO Touring Car BD-7

Reply

Old 12-18-2012, 07:44 PM
  #1321  
Tech Champion
iTrader: (27)
 
hanulec's Avatar
 
Join Date: Sep 2007
Location: @ the post office
Posts: 8,906
Trader Rating: 27 (100%+)
Default

Originally Posted by syndr0me View Post
The honeymoon is over.

I'm not giving up yet, but I'm close.
so what is next??
hanulec is offline  
Reply With Quote
Old 12-18-2012, 07:51 PM
  #1322  
Tech Elite
iTrader: (25)
 
Join Date: Aug 2001
Location: Los Angeles, CA
Posts: 4,083
Trader Rating: 25 (100%+)
Default

Originally Posted by hanulec View Post
so what is next??
Fire sale, crackhead deal? Hmm
MDawson is offline  
Reply With Quote
Old 12-18-2012, 08:17 PM
  #1323  
Tech Lord
iTrader: (32)
 
syndr0me's Avatar
 
Join Date: Dec 2004
Location: 5280 Raceway
Posts: 13,206
Trader Rating: 32 (100%+)
Default

I think Mark is on to something with the shocks. I'm gonna give T-Shox a try. After that doesn't work, probably a T4.
syndr0me is offline  
Reply With Quote
Old 12-18-2012, 08:22 PM
  #1324  
Tech Elite
iTrader: (8)
 
NolanP's Avatar
 
Join Date: Apr 2012
Location: Westmont
Posts: 2,426
Trader Rating: 8 (100%+)
Default

Originally Posted by syndr0me View Post
I think Mark is on to something with the shocks. I'm gonna give T-Shox a try. After that doesn't work, probably a T4.
I'm gonna try the old caps with the screw bleeder for the Yok at some point but I under no circumstances will give this car up for asphalt.
NolanP is offline  
Reply With Quote
Old 12-18-2012, 08:22 PM
  #1325  
Tech Champion
iTrader: (27)
 
hanulec's Avatar
 
Join Date: Sep 2007
Location: @ the post office
Posts: 8,906
Trader Rating: 27 (100%+)
Default

Originally Posted by syndr0me View Post
I think Mark is on to something with the shocks. I'm gonna give T-Shox a try. After that doesn't work, probably a T4.
Did u try the double o-ring setup yet?
hanulec is offline  
Reply With Quote
Old 12-18-2012, 08:23 PM
  #1326  
Tech Lord
iTrader: (32)
 
syndr0me's Avatar
 
Join Date: Dec 2004
Location: 5280 Raceway
Posts: 13,206
Trader Rating: 32 (100%+)
Default

Originally Posted by hanulec View Post
Did u try the double o-ring setup yet?
Hmm, nope.
syndr0me is offline  
Reply With Quote
Old 12-18-2012, 08:25 PM
  #1327  
Tech Elite
iTrader: (8)
 
NolanP's Avatar
 
Join Date: Apr 2012
Location: Westmont
Posts: 2,426
Trader Rating: 8 (100%+)
Default

Originally Posted by hanulec View Post
Did u try the double o-ring setup yet?
Did you try the optional blue o-rings vs. the black o-rings?
NolanP is offline  
Reply With Quote
Old 12-18-2012, 08:25 PM
  #1328  
Tech Elite
iTrader: (37)
 
caltek1's Avatar
 
Join Date: Mar 2007
Posts: 3,417
Trader Rating: 37 (100%+)
Default

I don't seem to be having the issues you guys are having running however I am running on asphalt. My shocks are still the same as when I built them two months ago. I run boosted 17.5 on medium to low grip tracks with only a slight variation to the standard Umino setup. Although I prefer the HPI silver springs front and rear. I also fitted the flurine coated shock shafts when I constructed my shocks as per kit with 450 yokomo shock oil. No issues so far touch wood with zero rebound.

Sorry to see you guy's are so disappointed in the car. Shame as it is certainly better than the BD5W which I really liked.

Later,

Calvin
caltek1 is offline  
Reply With Quote
Old 12-18-2012, 08:42 PM
  #1329  
Tech Lord
iTrader: (32)
 
syndr0me's Avatar
 
Join Date: Dec 2004
Location: 5280 Raceway
Posts: 13,206
Trader Rating: 32 (100%+)
Default

Originally Posted by NolanP View Post
Did you try the optional blue o-rings vs. the black o-rings?
Yeah, I'm running one of those with the black bladder. I vented the shocks which made them worse. I prefer rebound on this car, though it does bounce around the track more.

I had a couple of great experiences with the car, but it's been hit or miss since then. It's funny, I had a friend make this same complaint about his car for years, and I kept encouraging him to buy an xray because they're almost always the same. He finally did and is much happier for it. And here I am, now, not taking my own advice.

The car has a ton of upside, and I think it's something small we're missing, but at this point, I'm starting to fear it really is Ronald that makes the car look good, and not the other way around. That was always the question. I had hoped the answer would be different.
syndr0me is offline  
Reply With Quote
Old 12-18-2012, 09:09 PM
  #1330  
Tech Regular
 
Join Date: Oct 2011
Posts: 367
Default

What are you guys smoking over there? This car is an awesome car, your aparently missing something in the setup. The 2 orings are one of the things you should really try, also the coated shock shafts and black bladders. I believe most of those are on all setup sheets out there.
HawaiiBob is offline  
Reply With Quote
Old 12-18-2012, 09:14 PM
  #1331  
Tech Elite
iTrader: (9)
 
B00t13g's Avatar
 
Join Date: Mar 2012
Location: Houston, TX
Posts: 2,041
Trader Rating: 9 (100%+)
Default

I'm running the black bladders, two blue o rings and the ti nitride shock shafts. The car is great, I've never said it wasn't. I'm just not sure it's for me anymore.
B00t13g is offline  
Reply With Quote
Old 12-18-2012, 09:18 PM
  #1332  
Tech Elite
iTrader: (5)
 
bkspeedo's Avatar
 
Join Date: Nov 2007
Location: Fort Fun, CO
Posts: 3,147
Trader Rating: 5 (100%+)
Default

If you guys saw how Adam has his body mounted you might be telling him to go back to running Tyco's.
bkspeedo is offline  
Reply With Quote
Old 12-18-2012, 09:47 PM
  #1333  
Tech Lord
iTrader: (32)
 
syndr0me's Avatar
 
Join Date: Dec 2004
Location: 5280 Raceway
Posts: 13,206
Trader Rating: 32 (100%+)
Default

I fixed that with the new body.
syndr0me is offline  
Reply With Quote
Old 12-18-2012, 10:01 PM
  #1334  
Tech Elite
iTrader: (5)
 
bkspeedo's Avatar
 
Join Date: Nov 2007
Location: Fort Fun, CO
Posts: 3,147
Trader Rating: 5 (100%+)
Default

Originally Posted by syndr0me View Post
I fixed that with the new body.
I hope you let Art mount it for you
bkspeedo is offline  
Reply With Quote
Old 12-19-2012, 12:35 AM
  #1335  
Tech Adept
 
Spillertwo's Avatar
 
Join Date: Jan 2002
Posts: 249
Default

Have had the car now for 1 month and it is doing great. Running 5 turn mod on medium traction carpet and it is a world of difference from my former electric car which was a Losi.
I'm running it with the spec-r dcj's up front, black bladders and double o rings in the dampers and 2000 oil in the diff. It feels really good. Just have to fix the sporadic grip rolls but that is a combination between setup and driving style. Not easy to go to driving 1/10th touring if you come from 1/8th on road :-)
Spillertwo is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service