R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-20-2001, 05:05 PM   #1
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default GM3 Comm problems

About 2 weeks ago, I was going to cut the comm on my fairly new GM3 for the first time. It had about 2 weeks of 1/12 scale racing on it, and I thought it was time for a fresh comm and new brushes. I just made a very light pass, and the comm started to split apart! 1 of the 3 comm "plates" allmost came off. The motor is junk now, which isn't the end of the world. Just wondering if I did something wrong, or if this is a common problem??? It's actually a Fantom GM3.
JeffC is offline   Reply With Quote
Old 08-20-2001, 05:16 PM   #2
RCTech Member #2
 
TSR6's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2001
Posts: 5,951
Trader Rating: 5 (100%+)
Send a message via ICQ to TSR6
Default

My GM3 just burnt up... Poof she goes!

It was accually caught on tape too, which is cool.. lol
__________________
Troy
RCTech Member #2

The postings and views expressed on this site are my own and do not necessarily reflect the positions, strategies, or opinions of any company I may be employed by.
TSR6 is offline   Reply With Quote
Old 08-20-2001, 05:18 PM   #3
Tech Master
 
AE_Racer's Avatar
 
Join Date: Aug 2001
Location: Florida, USA
Posts: 1,127
Send a message via AIM to AE_Racer
Default

LOL, smoke and all? This is why I stayed with my P2K
AE_Racer is offline   Reply With Quote
Old 08-20-2001, 05:30 PM   #4
Tech Fanatic
 
minicooper's Avatar
 
Join Date: Aug 2001
Location: Beautiful Downtown L.A. Where the sky is always on fire and the grass is always brown
Posts: 949
Trader Rating: 5 (100%+)
Send a message via AIM to minicooper Send a message via Yahoo to minicooper
Default Re: GM3 Comm problems

Quote:
Originally posted by JeffC
About 2 weeks ago, I was going to cut the comm on my fairly new GM3 for the first time. It had about 2 weeks of 1/12 scale racing on it, and I thought it was time for a fresh comm and new brushes. I just made a very light pass, and the comm started to split apart! 1 of the 3 comm "plates" allmost came off. The motor is junk now, which isn't the end of the world. Just wondering if I did something wrong, or if this is a common problem??? It's actually a Fantom GM3.
That's awful, send it back with a note explaining what you did. I would if only to let them know that they are putting out an inferior product.
minicooper is offline   Reply With Quote
Old 08-20-2001, 05:30 PM   #5
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default

Yeah, I went back to P2K's in my sedan. Had been running the MVP, but I like to be able to touch the motor within an hour after running it! What's another good high RPM motor? I've heard the Reedy Rage is high RPM.
JeffC is offline   Reply With Quote
Old 08-20-2001, 05:32 PM   #6
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default

mini, I suppose I probably should. I'd still like to know if this is a common problem or not.
JeffC is offline   Reply With Quote
Old 08-20-2001, 05:41 PM   #7
Tech Master
 
AE_Racer's Avatar
 
Join Date: Aug 2001
Location: Florida, USA
Posts: 1,127
Send a message via AIM to AE_Racer
Default

The Rage is a high RPM motor, but be sure to gear it right
AE_Racer is offline   Reply With Quote
Old 08-20-2001, 06:01 PM   #8
Moderator
 
Speedo's Avatar
R/C Tech Charter Subscriber
 
Join Date: Aug 2001
Posts: 3,431
Cool

I geared my GM3 too high, and it went poof too!

Probably what happened is that fantom cut too much off the comm, so it was too small in the first place.

Speedo
Speedo is offline   Reply With Quote
Old 08-20-2001, 06:03 PM   #9
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default

Speedo, I never thought about that... You mean, I paid $38 for a stock motor that can never be cut? lame....

Last edited by JeffC; 08-20-2001 at 06:06 PM.
JeffC is offline   Reply With Quote
Old 08-20-2001, 06:11 PM   #10
Moderator
 
Speedo's Avatar
R/C Tech Charter Subscriber
 
Join Date: Aug 2001
Posts: 3,431
Unhappy

Yeah, Send the comm back, hopefully they will replace it. I bought a fantom GM3 too, and they are nothing special. You are better to save 8 bucks and just get the GM3 pro from trinity. I have a dyno, and it wasn't close to what the numbers said.
Speedo is offline   Reply With Quote
Old 08-20-2001, 06:12 PM   #11
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default

I suppose $5 of the $8 is just for the Fantom Sticker. you're right, I think I am better just getting the Trinity Pro version next time.
JeffC is offline   Reply With Quote
Old 08-20-2001, 06:26 PM   #12
Tech Master
 
AE_Racer's Avatar
 
Join Date: Aug 2001
Location: Florida, USA
Posts: 1,127
Send a message via AIM to AE_Racer
Default

Actually the Fantom P2K is better than the regular Pro, I was cutting .30s off my oval lap times just because I had a faster motor, and that was when they were both new...unless I just got a good one
AE_Racer is offline   Reply With Quote
Old 08-20-2001, 06:27 PM   #13
RCTech Member #2
 
TSR6's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2001
Posts: 5,951
Trader Rating: 5 (100%+)
Send a message via ICQ to TSR6
Default

Quote:
Originally posted by JeffC
I suppose $5 of the $8 is just for the Fantom Sticker. you're right, I think I am better just getting the Trinity Pro version next time.
Next time i will just buy a MVP

The GM3 is natorious for blowing, i just always thought it was after 4 weekends of racing... not 4 battery packs
__________________
Troy
RCTech Member #2

The postings and views expressed on this site are my own and do not necessarily reflect the positions, strategies, or opinions of any company I may be employed by.
TSR6 is offline   Reply With Quote
Old 08-20-2001, 06:37 PM   #14
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default

At least when your's broke, it probably looked cool... Mine broke on the lathe! I mean, if it breaks, but looks cool breaking, it's not so bad. But I just got screwed.
JeffC is offline   Reply With Quote
Old 08-20-2001, 06:41 PM   #15
Tech Addict
 
Join Date: Aug 2001
Location: Kenyon, MN
Posts: 716
Trader Rating: 3 (100%+)
Default

Troy, the MVP is pretty far from a GM3. It's a torque monster. It's no bulletproof motor either... Runs hot, and I bought one where one of the magnets had moved, and the motor was locked up. I've heard of other people having the same problem. I think it's been fixed since then, though. I've got 2 MVP's, and 4 P2K's. At times the MVP will be faster, and at times the P2K will be faster. So, I guess it would be worth picking one up, just to have it when you'll need it.
JeffC is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
HPI MT2 Problems kutters Nitro Off-Road 10 07-14-2007 04:30 PM
Hudy comm lathe and Fantom comm lathe ACEDEAN R/C Items: For Sale/Trade 0 05-02-2007 11:27 AM
Trade EXTREME COMM LATHE(Hudy)for MUCH MORE COMM LATHE JoeyE R/C Items: For Sale/Trade 0 05-07-2006 09:49 AM
RS4 Evo Problems somegeek Rookie Zone 1 04-10-2006 06:42 AM
Who is having problems with the SH .28??? hamburgler Monster Trucks 8 09-02-2005 08:27 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net