R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 06-30-2012, 08:20 AM   #1
Tech Master
 
theatriks's Avatar
 
Join Date: Jan 2011
Posts: 1,620
Trader Rating: 8 (100%+)
Default Team Orion Twin Spec charger issue

Hey guys a have a twin spec charger and have had it for a year and its worked great but.......but now on my channel 2 side every time i go to charge it goes crazy and reads like 13.3v offf a 2cell 5000 pack or it says check battery connection or it will read and start charging then the voltage jumps to like 8.7v and it still charges?????? ive tripled check my settings and have tried numerous batteries on that channel and always the same thing???...my batteries charge fine on channel 1 with no issues.....soooo im hoping this charger didnt already shit the bed as its only a year old. Any thoughts? Thanks.
theatriks is offline   Reply With Quote
Old 06-30-2012, 12:01 PM   #2
Tech Master
 
hanzo3's Avatar
 
Join Date: Aug 2007
Location: Anaheim Hills, CA
Posts: 1,293
Trader Rating: 55 (100%+)
Default

Sometimes the connection can get loose. Open it up and check or send it in for repair.
__________________
Chris TRF419 TA05V2
TQ RC Racing Powered by teeth
hanzo3 is offline   Reply With Quote
Old 06-30-2012, 03:42 PM   #3
Tech Master
 
theatriks's Avatar
 
Join Date: Jan 2011
Posts: 1,620
Trader Rating: 8 (100%+)
Default

So i opened it up and the visible connections are good im not gonna start moving circuit boards or anything ....but for the price you pay for this charger and then for this to happen......i will definately not be purchasing another charger from Team Orion every again!
theatriks is offline   Reply With Quote
Old 07-01-2012, 02:18 PM   #4
Tech Rookie
 
Join Date: Jul 2012
Posts: 1
Default Orion twin spec issue as well

I have a Orion twin spec charger that is new to me, it is used and in great condition. However it charges my lipos fine, but went to set it up to due NiNH batteries and it would not allow me to adjust to a different setting and the read out on the display would read: connect usb adaptor -please wait- then nothing can be done with the charger I have to turn off the power to reset charger. Any thoughts would be great.
Thanks
mdholeman
mdholeman is offline   Reply With Quote
Old 07-01-2012, 03:13 PM   #5
Tech Master
 
theatriks's Avatar
 
Join Date: Jan 2011
Posts: 1,620
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by mdholeman View Post
I have a Orion twin spec charger that is new to me, it is used and in great condition. However it charges my lipos fine, but went to set it up to due NiNH batteries and it would not allow me to adjust to a different setting and the read out on the display would read: connect usb adaptor -please wait- then nothing can be done with the charger I have to turn off the power to reset charger. Any thoughts would be great.
Thanks
mdholeman
Its seems our buddies over at Team Orion have no problem selling an inferior charger at a premium price....dont get screwed people and buy your chargers from a different company!!.....now lets just wait for the reps of orion to pose as a regular member and say there charger works fine for years lolol
theatriks is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:13 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net