R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 06-03-2007, 10:01 PM   #8611
Tech Master
 
Wing Chun's Avatar
 
Join Date: Aug 2006
Location: Gold Coast,Australia
Posts: 1,025
Trader Rating: 12 (100%+)
Default

Hi Guy's
Have many of you broke your Servo saver body ( the purple 75143a peice) I have now broke 2 of these and have found them very weak. They have broke where the collar threads on. One during a smash and one while doing up the collar.
Is there a repalacement stronger part that anyone knows of.
Have many of you guys had this problem or is it my brute strength that just does it.
BTW Simon
that setup for bumpy low grip tracks is a real hit I have sent over 20 to other guy's.

Thanks Addam
Wing Chun is offline   Reply With Quote
Old 06-03-2007, 10:37 PM   #8612
Tech Elite
 
A Ilievski's Avatar
 
Join Date: Apr 2005
Location: A.C.T (Australia)
Posts: 2,652
Trader Rating: 39 (100%+)
Default

Quote:
Originally Posted by Wing Chun View Post
Hi Guy's
Have many of you broke your Servo saver body ( the purple 75143a peice) I have now broke 2 of these and have found them very weak. They have broke where the collar threads on. One during a smash and one while doing up the collar.
Is there a repalacement stronger part that anyone knows of.
Have many of you guys had this problem or is it my brute strength that just does it.
BTW Simon
that setup for bumpy low grip tracks is a real hit I have sent over 20 to other guy's.

Thanks Addam

Ive broken 2 of them while tightening on the collar and broken 1 on the track. they are very brittle.
A Ilievski is offline   Reply With Quote
Old 06-03-2007, 10:44 PM   #8613
Tech Champion
 
Join Date: Jun 2004
Location: St Louis
Posts: 7,868
Trader Rating: 198 (100%+)
Default

Quote:
Originally Posted by BlackedOutREVO View Post
why does my cobalt stock motor run so dang hot?

i cant keep this dumb thing cool, not with fans, not with gearing... i mean, whats it take?

and then to top that crap, my ib's dont take in over 4000 mah!!!! im getting mad at this junk, my charger is set all right, i have tried everything.... they are new, 7 runs on each of them... is that good to where they are suposed to take full mah or?
Your motor may be hot because you have it over geared, tuned wrong, or are over driving the car. Are you racing or bashing?

If you are not dumping your IB's to all the way to 0 they will not take a full. mah charge. I would not pay to much attention to that. Unless they are way below 4000. If they are all doing it I would say normal. Or its the charger.
dodgeguy is offline   Reply With Quote
Old 06-03-2007, 10:55 PM   #8614
Tech Elite
 
fjm9898's Avatar
 
Join Date: Mar 2005
Location: Redmond, WA
Posts: 3,003
Trader Rating: 11 (100%+)
Default

what part r u talking about exactly? since you guys are breaking them i guess i would look into getting spares for nats
__________________
Xray '007 US and a bunch of other outdated stuff
fjm9898 is offline   Reply With Quote
Old 06-03-2007, 11:33 PM   #8615
Tech Elite
 
F. Alonso's Avatar
 
Join Date: Jan 2004
Location: Melbourne, Australia
Posts: 2,141
Trader Rating: 10 (100%+)
Send a message via AIM to F. Alonso Send a message via Yahoo to F. Alonso
Default

Quote:
Originally Posted by Wing Chun View Post
Hi Guy's
Have many of you broke your Servo saver body ( the purple 75143a peice) I have now broke 2 of these and have found them very weak. They have broke where the collar threads on. One during a smash and one while doing up the collar.
Is there a repalacement stronger part that anyone knows of.
Have many of you guys had this problem or is it my brute strength that just does it.
BTW Simon
that setup for bumpy low grip tracks is a real hit I have sent over 20 to other guy's.

Thanks Addam
Hi Addam,

Glad to hear that the setup is a hit with all... even if it does mean that it will be harder to win. Still... I'd rather see Cyclones flying fast then trundling around slow.

As far as your question about the servo saver post (the part with the thread on it), I have broken mine once on my Surikarn kit where the thread was. Never nice having your steering all floppy. Sad part is that I never looked at it until the Saturday night of our nationals in Queensland, and I was wondering why my car felt disjointed.

I didn't have a spare but I still had enough thread to do it up, provided that I didn't use the spring, so effectively I had no servo saver on the car. I ran it like that for the next few months without a hitch!
__________________
Simon Feigl
RCRacer.com.au - Dedicated Australian Forum and Website

XRAY | HPI | Hotbodies | Hobbies Australia | LRP Electronics | Futaba
F. Alonso is offline   Reply With Quote
Old 06-03-2007, 11:44 PM   #8616
Tech Master
 
Wing Chun's Avatar
 
Join Date: Aug 2006
Location: Gold Coast,Australia
Posts: 1,025
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by fjm9898 View Post
what part r u talking about exactly? since you guys are breaking them i guess i would look into getting spares for nats
This is the parts number
75143a
I am so glad that a few of you had broke your because I was going to blame my MUSCLES
Simon
I will be 107 years old before I beat you.
Addam
Wing Chun is offline   Reply With Quote
Old 06-04-2007, 12:20 AM   #8617
Tech Elite
 
F. Alonso's Avatar
 
Join Date: Jan 2004
Location: Melbourne, Australia
Posts: 2,141
Trader Rating: 10 (100%+)
Send a message via AIM to F. Alonso Send a message via Yahoo to F. Alonso
Default

Quote:
Originally Posted by Wing Chun View Post
Simon
I will be 107 years old before I beat you.
Addam
Pah, never say never.
__________________
Simon Feigl
RCRacer.com.au - Dedicated Australian Forum and Website

XRAY | HPI | Hotbodies | Hobbies Australia | LRP Electronics | Futaba
F. Alonso is offline   Reply With Quote
Old 06-04-2007, 07:21 AM   #8618
Tech Addict
 
ICEMAN's Avatar
R/C Tech Elite Subscriber
 
Join Date: Oct 2001
Location: Germantown, TN
Posts: 730
Trader Rating: 1 (100%+)
Default

Just wanted to post, Yesterday was my first outing with the BMI Chassis and it was AWESOME. what a difference over the stock one on pavement, the best upgrade i have bought.
ICEMAN is offline   Reply With Quote
Old 06-04-2007, 07:22 AM   #8619
Tech Elite
 
BillyCaldwell's Avatar
 
Join Date: Aug 2003
Location: OKC, Oklahoma
Posts: 4,005
Trader Rating: 32 (100%+)
Send a message via AIM to BillyCaldwell
Default

Pookyt said your car looked really good. I ran my Surikarn at the BTH last year and it was really good. Make sure to give Pookyt a love tap for me next time yall race.
BillyCaldwell is offline   Reply With Quote
Old 06-04-2007, 07:44 AM   #8620
Tech Addict
 
ICEMAN's Avatar
R/C Tech Elite Subscriber
 
Join Date: Oct 2001
Location: Germantown, TN
Posts: 730
Trader Rating: 1 (100%+)
Default

Yes the car was Pretty GOOD, just a little fine line tuning and it should be online,
__________________
Blizzard Concepts / Team Losi / Team ProMatch / Team MuchMore / The SPEED Shop / Ko Propo USA / AVID RC / BigDog Graphics / Nitro R/C Chop Shop /

The ONE that DIES with the Most Toys WINS!!!
ICEMAN is offline   Reply With Quote
Old 06-04-2007, 08:09 AM   #8621
Tech Elite
 
mangoman's Avatar
 
Join Date: Apr 2005
Location: Sydney, Australia
Posts: 2,981
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by BlackedOutREVO View Post
my ib's dont take in over 4000 mah!!!
Um probably not the best thread to be asking battery and motor questions but dont discharge your IBs and leave them for more than a day or so discharged.

If you are stock racing you dont need more than 3000 mah, as long as the batteries still have good volts why are you worried?

My batteries are about the same taking about 4000 charge from about .9 but still feel strong at the end of 5 minutes of 19T. It only takes out about 2200 for a 5 minute run including a couple laps of warmups.

If your motor is running hotter than other peoples than the most likely reasons are you have it geared wrong, you have a dud or you are not maintaining your motors. How do you know its hot what is the temperature, and what is the temperature of other peoples who are running the same rollout.
mangoman is offline   Reply With Quote
Old 06-04-2007, 08:12 AM   #8622
Tech Master
 
Wing Chun's Avatar
 
Join Date: Aug 2006
Location: Gold Coast,Australia
Posts: 1,025
Trader Rating: 12 (100%+)
Default

Hey Ice
Post some pic's of your new Chassis,
Addam
Wing Chun is offline   Reply With Quote
Old 06-04-2007, 10:32 AM   #8623
Tech Elite
 
BlackedOutREVO's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2007
Location: CA
Posts: 3,791
Trader Rating: 67 (100%+)
Default

Quote:
Originally Posted by dodgeguy View Post
Your motor may be hot because you have it over geared, tuned wrong, or are over driving the car. Are you racing or bashing?

If you are not dumping your IB's to all the way to 0 they will not take a full. mah charge. I would not pay to much attention to that. Unless they are way below 4000. If they are all doing it I would say normal. Or its the charger.


but isnt over geared making the speedo hot? and under geared is a hot motor?

im racing.. i have used fans and all, and it runs hot.. i guess maybe im still under geared?

and u know i think it mite be my charger, i am discharging them to .9 volts, and then charging them back up at 5.5 amps, and theres all the lil settings that i have been told to charge them at. or are they just nt cycled yet and are being a pita? because i thought it was my 2 fans killing it, but then i went and looked at the numbers and the charger only puts in 4000 or less, every time so far on bolth
BlackedOutREVO is offline   Reply With Quote
Old 06-04-2007, 10:38 AM   #8624
Tech Elite
 
BlackedOutREVO's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2007
Location: CA
Posts: 3,791
Trader Rating: 67 (100%+)
Default

Quote:
Originally Posted by mangoman View Post
Um probably not the best thread to be asking battery and motor questions but dont discharge your IBs and leave them for more than a day or so discharged.

If you are stock racing you dont need more than 3000 mah, as long as the batteries still have good volts why are you worried?

My batteries are about the same taking about 4000 charge from about .9 but still feel strong at the end of 5 minutes of 19T. It only takes out about 2200 for a 5 minute run including a couple laps of warmups.

If your motor is running hotter than other peoples than the most likely reasons are you have it geared wrong, you have a dud or you are not maintaining your motors. How do you know its hot what is the temperature, and what is the temperature of other peoples who are running the same rollout.

i know that, but either they are dumping, or the motor is not performing because of the heat.... it running at 160+, doesnt smell lik its burning, but idk how hot these things can get before they start performing worse

i maintain it, i always clean it up good, i get my comm cut from racers, replace the brushes etc.... the comm harldy ever get marks on it when i clean it, i put 4 runs max on it before it gets torn down and all sprayed out and all that, and about 9 runs before a cut and brushes
BlackedOutREVO is offline   Reply With Quote
Old 06-04-2007, 12:34 PM   #8625
Tech Regular
 
Elboogie's Avatar
 
Join Date: Apr 2007
Posts: 329
Default

Quote:
Originally Posted by protc3 View Post
it will fit.
Cool, thanks for the info Pro.
__________________
CYCLONE WCE
Jaco / Airtronics
Much More / Team Orion

"Drive Hard or Go Home"
Elboogie is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hot Bodies Cyclone S wardyl Electric On-Road 4 10-01-2008 08:01 AM
Hot bodies Cyclone 12 k7king R/C Items: For Sale/Trade 1 09-04-2008 08:09 AM
WTB Hot Bodies Cyclone/ cyclone Parts tenpins77 R/C Items: Wanted to Buy 0 07-29-2008 08:48 AM
Hot Bodies Cyclone sdt1 Australia For Sale/Trade 6 07-13-2008 03:05 AM
WTB: Cyclone S/Cyclone Painted bodies vazzo Australia Wanted to Buy 0 02-05-2008 06:15 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:50 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net