Like Tree1Likes

Xray T1FK05

Old 05-16-2005, 09:52 AM
  #2296  
Tech Regular
iTrader: (5)
 
Join Date: May 2004
Location: Cleveland, Ohio
Posts: 338
Trader Rating: 5 (100%+)
Default Thrust Bearing Info from RC America

I copied this from the forum on Xray's website.

We received the trust bearings in the middle of last week. We mailed a large number of bearings out on Thursday, May 12. If we had received your email before May 12, your bearings were mailed out. We should have another batch leaving today or tomorrow.

Due to the large number of customers in need of bearings, we have not been sending confirmation messages upon receipt of every email. Obviously this has caused some confusion, and I apologize for that. I will send either a shipping confirmation or receipt confirmation today for all customers who have contacted us.

Bryan
RC America
brianrice is offline  
Old 05-16-2005, 12:21 PM
  #2297  
Tech Regular
iTrader: (10)
 
kyle "hitawall"'s Avatar
 
Join Date: Mar 2005
Location: Orlando
Posts: 496
Trader Rating: 10 (100%+)
Default

i posted ealier that my car was loose off power. i thought it was fixed but now it is back to being loose. the car is great when the track is cool, but when the track heats up the car is crap. i tride putting more drop in the rear, going from 3 to 2 hples open in the front shocks, putting a front sway bar on, taking weight out of the front and also out of the rear, and also going from light blue to blue springs in the front.
kyle "hitawall" is offline  
Old 05-16-2005, 01:06 PM
  #2298  
Tech Elite
iTrader: (87)
 
Midnight's Avatar
 
Join Date: Feb 2003
Location: Edmond. Oklahoma
Posts: 2,107
Trader Rating: 87 (100%+)
Default

Hey Bro it doesnt sound like your setup, it sounds like your tires are heating up to much. I had the same problem every year around the same time. During practice my 27s are perfect then later when the building gets more heat they go away. I have found out that if I run the 32s when it gets hot they last the whole race, but they are kind of icey at first so you have to take two or three laps to get them heated up, or you can break out the tire warmers. Hope this helps.

Whats your set up? What type of track do you run on?
Originally posted by kyle "hitawall"
i posted ealier that my car was loose off power. i thought it was fixed but now it is back to being loose. the car is great when the track is cool, but when the track heats up the car is crap. i tride putting more drop in the rear, going from 3 to 2 hples open in the front shocks, putting a front sway bar on, taking weight out of the front and also out of the rear, and also going from light blue to blue springs in the front.
Midnight is offline  
Old 05-16-2005, 02:50 PM
  #2299  
Tech Fanatic
 
TeamPink91's Avatar
 
Join Date: Jan 2004
Location: Central FL
Posts: 767
Default

i posted ealier that my car was loose off power. i thought it was fixed but now it is back to being loose. the car is great when the track is cool, but when the track heats up the car is crap. i tride putting more drop in the rear, going from 3 to 2 hples open in the front shocks, putting a front sway bar on, taking weight out of the front and also out of the rear, and also going from light blue to blue springs in the front.
Hey Kyle, this last race at TQ I noticed my tires at the end of a run being hot as hell, so that could be a problem. Good luck man!
TeamPink91 is offline  
Old 05-16-2005, 05:31 PM
  #2300  
Tech Fanatic
iTrader: (33)
 
HRCRACER123's Avatar
 
Join Date: Apr 2005
Location: Long Island, New York
Posts: 819
Trader Rating: 33 (100%+)
Default

Anybody have a problem with stripping out the bottom silver chassis screws? I use my 2mm green integy wrench and It seems to strip the screws. What wrench do you guys use?

Last edited by HRCRACER123; 05-16-2005 at 05:37 PM.
HRCRACER123 is offline  
Old 05-16-2005, 05:37 PM
  #2301  
Tech Master
iTrader: (4)
 
polesitter61's Avatar
 
Join Date: Feb 2005
Location: Central Florida
Posts: 1,009
Trader Rating: 4 (100%+)
Default

Got my exchange axial bearings in the mail today from RC America! Only took about 10 days from when I sent the e-mail to them!
polesitter61 is offline  
Old 05-16-2005, 06:09 PM
  #2302  
Tech Regular
 
Join Date: Dec 2004
Location: Oshawa, Ontario
Posts: 444
Default

Originally posted by HRCRACER123
Anybody have a problem with stripping out the bottom silver chassis screws? I use my 2mm green integy wrench and It seems to strip the screws. What wrench do you guys use?

HRCRacer, are you taking the threads off the screws or rounding them out with the wrench?

I have only rounded 2 screws (using the cheap allen keys) Not stripped any threads yet... Mebbe you dunno your own strength?
MartynD is offline  
Old 05-16-2005, 07:59 PM
  #2303  
Tech Fanatic
iTrader: (33)
 
HRCRACER123's Avatar
 
Join Date: Apr 2005
Location: Long Island, New York
Posts: 819
Trader Rating: 33 (100%+)
Default

Martyn. I am rounding the hexes with brand new drivers. I went through 2 brand new tips. I just thinks its not the right tool for those screws. I give up.. I am the only one with this problem?
HRCRACER123 is offline  
Old 05-16-2005, 08:06 PM
  #2304  
Tech Regular
 
Join Date: Dec 2004
Location: Oshawa, Ontario
Posts: 444
Default

Well the screws are aluminum.

I use a 5/64 driver, but I also have a 2mm round head, but I don't use it on the aluminum chassis screws. I am told that usually a 5/64 driver is actually the same as 2mm...

I use Titan drivers, and no problems. APS sells stainless steel screws, doubt you will round those off, though then if you aren't careful you risk stripping the threads in the bulkheads... Eventually I will replace all the screws with stainless but right now the alu ones are in good shape..
MartynD is offline  
Old 05-16-2005, 08:39 PM
  #2305  
Tech Regular
iTrader: (12)
 
Join Date: Oct 2004
Location: Anaheim Hills, CA
Posts: 285
Trader Rating: 12 (100%+)
Default Re: Thrust Bearing Info from RC America

Originally posted by brianrice
I copied this from the forum on Xray's website.

We received the trust bearings in the middle of last week. We mailed a large number of bearings out on Thursday, May 12. If we had received your email before May 12, your bearings were mailed out. We should have another batch leaving today or tomorrow.

Due to the large number of customers in need of bearings, we have not been sending confirmation messages upon receipt of every email. Obviously this has caused some confusion, and I apologize for that. I will send either a shipping confirmation or receipt confirmation today for all customers who have contacted us.

Bryan
RC America
Cool Bryan, I just received the confirmation E-Mail from you today, it's nice to know. Also, just got the Multi-Diff and the 1-Way lube I've ordered today. Got the Multi-Diff set-up in the car as a locked one-way, I can't wait to try that badboy out this weekend!!

Thanx,

Stan
skinart76 is offline  
Old 05-16-2005, 08:53 PM
  #2306  
Tech Addict
 
Eric Gebhard's Avatar
 
Join Date: Aug 2004
Posts: 508
Default

Originally posted by MartynD
Well the screws are aluminum.

I use a 5/64 driver, but I also have a 2mm round head, but I don't use it on the aluminum chassis screws. I am told that usually a 5/64 driver is actually the same as 2mm...

I use Titan drivers, and no problems. APS sells stainless steel screws, doubt you will round those off, though then if you aren't careful you risk stripping the threads in the bulkheads... Eventually I will replace all the screws with stainless but right now the alu ones are in good shape..
Actually the screws are stainless. I use a Hudy wrench and haven't had any issues, yet.
Eric Gebhard is offline  
Old 05-16-2005, 09:15 PM
  #2307  
Tech Elite
iTrader: (10)
 
Roger's Avatar
 
Join Date: Feb 2003
Posts: 2,329
Trader Rating: 10 (100%+)
Default

Originally posted by HRCRACER123
Anybody have a problem with stripping out the bottom silver chassis screws? I use my 2mm green integy wrench and It seems to strip the screws. What wrench do you guys use?
Hudy wrenches.
Roger is offline  
Old 05-16-2005, 09:29 PM
  #2308  
Tech Elite
iTrader: (10)
 
Roger's Avatar
 
Join Date: Feb 2003
Posts: 2,329
Trader Rating: 10 (100%+)
Default

where can I order PRS spurgears online ? Thx guys.
Roger is offline  
Old 05-16-2005, 09:39 PM
  #2309  
Tech Elite
iTrader: (11)
 
ChrisP's Avatar
 
Join Date: Sep 2003
Location: Shelby Twp, MI
Posts: 2,184
Trader Rating: 11 (100%+)
Default

http://teameamotorsports.com/ has them in stock right now I believe....great guy to deal with
ChrisP is offline  
Old 05-17-2005, 03:52 AM
  #2310  
Tech Addict
 
acutts's Avatar
 
Join Date: Nov 2003
Location: London, UK
Posts: 507
Default

Has anyone got the 3mm chassis .... the one that has pre-milled battery slots? Can anyone confirm if this chassis fits 3700 cells better .... in other words have they made any changes to the slots?
acutts is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.