R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 03-09-2012, 07:44 PM   #1
Tech Rookie
 
darcrai98's Avatar
 
Join Date: Mar 2012
Location: Wales, Swansea.
Posts: 9
Unhappy I need Help! D:

I'm new to RC Racing and my motor started sparking and my car does not work now :/ , what is wrong with it?
darcrai98 is offline   Reply With Quote
Old 03-09-2012, 07:49 PM   #2
Tech Master
R/C Tech Elite Subscriber
 
Join Date: Oct 2008
Location: Grand Portage, MN
Posts: 1,368
Trader Rating: 41 (100%+)
Default

As there is little information to go from and I am not clairvoyant but I might guess you have a stock Motor possibly Brushed.

If that's the case I would say the motor either got too hot or dirty and the brushes are done.

If it's a sealed endbell you are out of luck with repairing the motor and it's time to upgrade.
__________________
______________________________________________
Jason Deadman

I race toy cars for fun. If I need to explain, you'll never understand.
jdeadman is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Im New In RC Drifting! I Need Help, Recommendations and tipz Newbie2Probie Brunei R/C Racers 15 10-08-2010 09:16 PM
I Need Help In Building My Crawler wgn_white Crawler Room 16 04-22-2010 09:09 PM
i need help. i'm a newbie to these kinds of stuff Hang_TiMe Rookie Zone 12 09-24-2007 03:35 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:50 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net