Go Back  R/C Tech Forums > General Forums > Electric On-Road
Novak Edge vs LRP SXX Comp/TC V2 >

Novak Edge vs LRP SXX Comp/TC V2

Novak Edge vs LRP SXX Comp/TC V2

Reply

Old 03-05-2012, 06:26 AM
  #16  
Tech Adept
iTrader: (4)
 
Join Date: Mar 2009
Posts: 181
Trader Rating: 4 (100%+)
Default which speedo

Hey J-Pap, I run a novak edge in my f104 and I have to say I really like it. The size is perfect for the small mounting spaces in the 104. I mount mine inline in the rear and run a shorty lipo. You can however run it on the side plates with no problems, and like I said the small size makes it ideal for f1.
mrod is offline  
Reply With Quote
Old 04-15-2012, 05:44 PM
  #17  
Tech Master
iTrader: (42)
 
Join Date: Sep 2009
Location: central GA
Posts: 1,220
Trader Rating: 42 (100%+)
Default

I have a novak Edge in my 17.5 spec class car, we have to run the 17.5 monster locked 17.5 with a 4.0 gear. I turned it on checked for steering and power like every time and set it in a corner and walked up to the drivers stand. That was the last time it worked.. I walked up to it and noticed that I have no lights on my transponder, receiver, and my fan was not running. it has a solid red light on and that is all it will do at this point... any thought on this.. the bad thing is I was one of 5 of them today that all failed to work by the end of the day..

I am running the 17.5 trinity monster locked motor with radiopost radio and a savox 1251 servo on a TC6 just in case any of that matters..
BIGTRUX is offline  
Reply With Quote
Old 04-15-2012, 08:36 PM
  #18  
Tech Addict
iTrader: (13)
 
Join Date: Mar 2007
Location: colorado springs, co
Posts: 507
Trader Rating: 13 (100%+)
Default

hello,
I run a Novak Edge in my TC5. I use a novak ballistic 17.5 motor and we are supposed to use "blinky" esc's. My Edge does not have any timing built into the esc. However, when I turn it on, it does not blink. I can't find anywhere in the instructions that state it is even supposed to blink.
rc_speed is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service