R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-07-2012, 02:44 AM   #1
Tech Initiate
 
Join Date: Sep 2009
Posts: 23
Trader Rating: 1 (100%+)
Default Problem with LRP SXX TC Spec V2

Hi guys!

I just bought an LRP SXX TC Spec V2 ESC and I have a big problem!

When I turn everything on and I am near the car everything works great.
If a walk 15 feet away the car goes crazy like there are interferences.

This looked strange because I never had issues with my receiver, so I tried to use a 6V pack to power the receiver instead of getting power from the ESC. After that everything worked fine.

So, I am thinking that something is going wrong with the ESC and it doesn't supply my receiver with adequate voltage/current.

Has anyone faced this issue????

Thanks a lot!!!
panayos is offline   Reply With Quote
Old 02-07-2012, 03:28 AM   #2
piper48
Guest
 
Posts: n/a
Default glitching

I had the same exact same problem but with a SXX V2 Comp. About a year ago I was running a M11 with the 75mhz crystal receivers. I had three receivers in three cars for three different applications with no problems. I ran an SPX boosted 13.5, SP GT 2.0 for TC 17.5 stock, and one in my NT1 nitro car. Anyways my Speedpassion took a dump so I bought the SXX V2 Comp for 17.5 TC stock. Well for some reason the car worked great within a 20ft but had major glitching beyond that. I hooked up a 2.4 ghz system to that ESC and it works great. Long story short, I ended up buying a 2.4ghz radio so I could run it. So if your still running crystals in your receiver that may be the problem.
  Reply With Quote
Old 02-07-2012, 03:36 AM   #3
Tech Initiate
 
Join Date: Sep 2009
Posts: 23
Trader Rating: 1 (100%+)
Default

I am running crystals at 75MHz.
But according to LRP the ESC can give 6V/3A. This seems to be enough...

Did you ask them about it??

I don't want to spend another $500 for a new radio.
At least they should mention that it is not going to work and I would have bought a different receiver!!!
panayos is offline   Reply With Quote
Old 02-07-2012, 03:44 AM   #4
piper48
Guest
 
Posts: n/a
Default

I didn't ask LRP but I did ask the owner of the hobbystore/track who is also a Associated sponsored driver seems to think that it's the newer software that's in these newer ESC's makes them incompatible with older radios. Try hooking it up to a friends 2.4ghz system to test it out.
  Reply With Quote
Old 02-07-2012, 03:46 AM   #5
piper48
Guest
 
Posts: n/a
Default

You could also try uploading LRPs newest software to see if it cures the problem.
  Reply With Quote
Old 02-07-2012, 03:59 AM   #6
Tech Initiate
 
Join Date: Sep 2009
Posts: 23
Trader Rating: 1 (100%+)
Default

I just saw that you are racing at the Hangar!
I just bought my TC 6.1 and I was planning to come this Wednesday for my first time but now I don't know if I can make it...

I installed firmware 4 and the problem still exists.
I really don't want to pay for a new radio!
I strongly believe that they should mention that older radios will have problems.
panayos is offline   Reply With Quote
Old 02-07-2012, 08:49 AM   #7
piper48
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by panayos View Post
I just saw that you are racing at the Hangar!
I just bought my TC 6.1 and I was planning to come this Wednesday for my first time but now I don't know if I can make it...

I installed firmware 4 and the problem still exists.
I really don't want to pay for a new radio!
I strongly believe that they should mention that older radios will have problems.
Sorry to hear the problem still exist. If they told people they would probably sell less. I'll be at the Hangar Wednesday and if you want we could plug into my 4PK and test it out. LMK
  Reply With Quote
Old 02-07-2012, 11:38 AM   #8
Tech Initiate
 
Join Date: Sep 2009
Posts: 23
Trader Rating: 1 (100%+)
Default

I just sent an email to LRP about the issue.

They told me that it should work totally fine with 75MHz radios and that I would better send the ESC to them because something seems to have gone wrong.
panayos is offline   Reply With Quote
Old 02-07-2012, 11:56 AM   #9
Tech Adept
 
Join Date: Jun 2006
Location: Sydney
Posts: 128
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by piper48 View Post
I didn't ask LRP but I did ask the owner of the hobbystore/track who is also a Associated sponsored driver seems to think that it's the newer software that's in these newer ESC's makes them incompatible with older radios. Try hooking it up to a friends 2.4ghz system to test it out.
Thats pretty shitty if that is in fact the case and they dont warn you!
roylo is offline   Reply With Quote
Old 02-07-2012, 12:08 PM   #10
Tech Rookie
 
Join Date: Mar 2010
Posts: 15
Default

Many guys here are running the same ESC with crystal receivers and they don't have the problem. Do send the speedo to them. I am pretty confident they'll solve the issue.
TeroRider is offline   Reply With Quote
Old 02-07-2012, 01:00 PM   #11
piper48
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by roylo View Post
Thats pretty shitty if that is in fact the case and they dont warn you!
Yeah it is but I think LRP or hobby shops that sell the products have no idea that there may be isolated cases where there's a problem between crystal radios and their ESCs so you can't really blame them. This may just be a faulty ESC. Good luck Panayos.
  Reply With Quote
Old 02-07-2012, 01:02 PM   #12
Tech Initiate
 
Join Date: Sep 2009
Posts: 23
Trader Rating: 1 (100%+)
Default

Thanks piper48!!

I am really sad that I will miss the races tomorrow and on Saturday.

I hope the process of sending back, etc. won't take too long...
panayos is offline   Reply With Quote
Old 02-07-2012, 01:20 PM   #13
piper48
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by panayos View Post
Thanks piper48!!

I am really sad that I will miss the races tomorrow and on Saturday.

I hope the process of sending back, etc. won't take too long...
I've got an SPX you can borrow for Wednesday and Saturday if you want. Show up, drop it in, and you'll be all set. Let me know and I'll bring tomorrow.
  Reply With Quote
Old 02-07-2012, 01:27 PM   #14
Tech Initiate
 
Join Date: Sep 2009
Posts: 23
Trader Rating: 1 (100%+)
Default

You are the best!!!!
If you can do that, it would be great!!!!

It is going to be my first time in Seattle and the electric class, I have prepared everything for the race and I was really sad about this ESC issue!!!!

If for ANY reason you need your SPX the last moment or anything, just tell me and I won't borrow it!

Thank you so much!!!!
panayos is offline   Reply With Quote
Old 02-07-2012, 01:44 PM   #15
piper48
Guest
 
Posts: n/a
Default

Any way to help a fellow racer out. I'm not using it so you can borrow it. Look for me tomorrow or ask for Lem. I'm the fat ugly guy with the beard. Good to have new racers join in on the fun. The Hangar has a great program and all the people are great. See ya tomorrow.
  Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LRP SXX TC, Comp, & Stock Specs QDRHRSE Electric Off-Road 74 05-23-2013 03:35 AM
lrp sxx tc spec v2 with update problem yankeefan2.0 Electric On-Road 7 12-22-2011 08:36 PM
Problem with LRP SXX TC SPEC V2 OoD1S Australian Racing 11 09-30-2011 03:44 AM


Tags
lrp sxx problem


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net