R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 12-23-2011, 11:21 PM   #1
Tech Rookie
 
Join Date: Dec 2011
Posts: 16
Default HPI e10 DRIFT ISSUES

Hey everyone just got into the rc drifting scene and picked up an hpi drift e10 brand new at a local hobby shop got it home charged the battery and cant seem to get it to respond to the REmote.

The Led on the motor just keeps blinking it not staying steady as it suggest in the manual and cant seem to get it working PLEASE HELP AS I AM TRYING TO BE SIDEWAYS ASAP lol Happy drifting
silentek is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbies Queries - Ask and you shall be answered! renben Singapore R/C Racers 4621 12-02-2017 09:30 PM
HPI E10 riceman777 Electric On-Road 12 03-27-2013 10:31 PM
Temasek Polytechnic Drift challenge by HPI - Tai Sing (27 Mar 2010) SIA Singapore R/C Racers 144 03-28-2010 07:20 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net