Go Back  R/C Tech Forums > General Forums > Electric On-Road
HELP ESC SPEED PASSION GT2.0 >

HELP ESC SPEED PASSION GT2.0

HELP ESC SPEED PASSION GT2.0

Reply

Old 12-13-2011, 04:22 AM
  #1  
Tech Rookie
Thread Starter
 
speedwork's Avatar
 
Join Date: Apr 2009
Posts: 13
Default HELP ESC SPEED PASSION GT2.0

Help ...
When connecting my esc GT2.0 Speed ​​Passion, just connecting the battery cables reversed.
After the speed it still worked for a few minutes, however the car did not move as before.
After that the speed stopped working.
I can not even resetting it.
The radio and receiver is working perfectly.
Does the esc went into some protection mode?
at the end of you need help.
thank you

Kenedi Quequi.
speedwork is offline  
Reply With Quote
Old 12-13-2011, 04:47 AM
  #2  
Tech Elite
 
COBRARACING's Avatar
 
Join Date: Nov 2007
Posts: 3,337
Default

Originally Posted by speedwork View Post
Help ...
When connecting my esc GT2.0 Speed ​​Passion, just connecting the battery cables reversed.
After the speed it still worked for a few minutes, however the car did not move as before.
After that the speed stopped working.
I can not even resetting it.
The radio and receiver is working perfectly.
Does the esc went into some protection mode?
at the end of you need help.
thank you

Kenedi Quequi.
Did you have a capacitor bank connected?
COBRARACING is offline  
Reply With Quote
Old 12-13-2011, 09:35 AM
  #3  
Tech Elite
iTrader: (27)
 
LMRacing's Avatar
 
Join Date: Nov 2008
Location: Rome, GA
Posts: 2,739
Trader Rating: 27 (100%+)
Default

You probobly damaged somthing inside the ESC that eventualy burnt up completely. Reversing power cables is almost always instant death to ESC's
LMRacing is offline  
Reply With Quote
Old 12-13-2011, 10:11 AM
  #4  
Tech Master
iTrader: (1)
 
Join Date: Feb 2009
Posts: 1,920
Trader Rating: 1 (100%+)
Default

the speedo is fried ,

most if not all speedos dont like having reverse polarity
sidecarphil1 is offline  
Reply With Quote
Old 12-13-2011, 10:48 AM
  #5  
Tech Champion
iTrader: (17)
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,138
Trader Rating: 17 (100%+)
Default

Originally Posted by speedwork View Post
Help ...
When connecting my esc GT2.0 Speed ​​Passion, just connecting the battery cables reversed.
After the speed it still worked for a few minutes, however the car did not move as before.
After that the speed stopped working.
I can not even resetting it.
The radio and receiver is working perfectly.
Does the esc went into some protection mode?
at the end of you need help.
thank you

Kenedi Quequi.
You have the reverse polarity, and you still ran it for a few minutes? That ESC did way more then others can..........when most ppl reverse polarity, the ESC will instantly SMOKE then EXPLODE if you keep letting that happen.

You are lucky that ESC does not blow up in front of you.........

Just to double check......do you see any lights at the bottom of the ESC? Also, does the servo works with the radio when you turn on the ESC...?
Solara is offline  
Reply With Quote
Old 12-13-2011, 07:22 PM
  #6  
Tech Rookie
Thread Starter
 
speedwork's Avatar
 
Join Date: Apr 2009
Posts: 13
Default HELP ESC SPEED PASSION

Hello everybody
I do not have capacitors installed

Yes smoke after leaving it still worked for a while

I was thinking of sending the esc to the Speed ​​Passion factory in China, it will be worth it?

Another option would be to purchase this esc.
http://www.hobbywing.com/english/Art...?ArticleID=464
speedwork is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service