Go Back  R/C Tech Forums > General Forums > Electric On-Road
New To Me HPI Sprint 2 Flux. Really Slow, What To Check? >

New To Me HPI Sprint 2 Flux. Really Slow, What To Check?

New To Me HPI Sprint 2 Flux. Really Slow, What To Check?

Reply

Old 10-22-2011, 06:41 PM
  #1  
Tech Adept
Thread Starter
 
Join Date: Oct 2011
Posts: 103
Default New To Me HPI Sprint 2 Flux. Really Slow, What To Check?

I just acquired a lightly used Sprint 2 Flux. It only seem to be able to go around 15-20 MPH on a 6 cell NIMH. It seems really slow, and I believe that there is something wrong. I purchased a castle link to see if any settings had been thrown out of whack on the ESC as the previous owner had mentioned he had used a castle link on it before.

It seems to drive smooth, but acts like it is in training mode or something. I have 2 2S lipo's coming from Tower, and have a 3S now (But it seems that ESC is only 2S capable, at least with the 5700kv motor), but in the meanwhile I will be using a 6 cell NIMH. Any suggestions? What speeds should I expect out of this thing with a 6 cell/2s? It is basically stock other than a 2.4Ghz traxxas controller/receiver. I have a Traxxas 4x4 Slash, so brushless components can be swapped if needed to verify any bad components.
NFA Fabrication is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service