R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-01-2011, 06:03 PM   #1
Tech Rookie
 
Join Date: Dec 2004
Posts: 3
Default HPI E10 main shaft issue

Hey guys I've installed the alloy main shaft for my E10 and the silver ring that supports the bearing for the rear diff gear keeps falling out and spinning along the shaft and makes the rear shaft gear unstable and it doesn't make decent contact with the diff.

Can someone post up a link/guide/pdf to instructions on installing this hop-up please. I have a feeling I'm not doing it right Haha

thanks
H-S-V is offline   Reply With Quote
Old 09-04-2011, 09:21 PM   #2
Tech Rookie
 
Join Date: Dec 2004
Posts: 3
Default

Can anybody help
H-S-V is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
E10 Upgrade newbie1111 Singapore R/C Racers 7 08-19-2009 06:16 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net