R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-27-2011, 03:43 PM   #1
Tech Master
 
Join Date: Jul 2008
Location: Hobart TAS Australia
Posts: 1,043
Trader Rating: 17 (100%+)
Default X12 rotor

Hi all,
Have a stockspec X12 13.5 motor that let go last race meeting.
After pulling it apart I found that the magnet has come loose off the rotor shaft, nothing smashed though, it's still all in one piece,Can the magnet just be glued back in place in some way or do I just get another rotor
Thanks Lee
__________________
Team Awesomatix
R1 Wurks
RC Maker.com
Southern Tasmania Model Car Club
lethallee69 is offline   Reply With Quote
Old 08-27-2011, 05:08 PM   #2
Tech Elite
 
Skiddins's Avatar
 
Join Date: Feb 2006
Location: Windsor, UK
Posts: 4,761
Default

I know a couple of people who have re-glued their rotors but I'm afraid I don't know what glue they used.

Skiddins
__________________
Xray T4'18, T4'14 (Wet Car)
Xray X12 2018
Xray X1'16
wlrc.co.uk (West London Racing Centre)
RCDisco.co.uk
Skiddins is offline   Reply With Quote
Old 08-28-2011, 03:47 AM   #3
Tech Fanatic
 
Join Date: Apr 2011
Location: France
Posts: 812
Default

this is becoming quite common now, maybe we should get back to LRP about this recurring problem.

Anyone from LRP on this forum?

otherwise, epoxy resin will be ok to glue it back
__________________
Electriquement votre...

Drink EARTH water and save lives! in support of WFP
olly986 is offline   Reply With Quote
Old 08-28-2011, 01:17 PM   #4
Tech Fanatic
 
daleburr's Avatar
 
Join Date: May 2010
Location: Oxfordshire, UK
Posts: 861
Default

Had exactly the same issue today.

Another guy at the track said they can be superglued back together, so may give it a try.
__________________
Team Xray
RC-Timing Software - http://www.rc-timing.com
Mercedes AMG F1 - http://www.mercedes-amg-f1.com/
daleburr is offline   Reply With Quote
Old 08-28-2011, 03:08 PM   #5
Tech Master
 
Join Date: Jul 2008
Location: Hobart TAS Australia
Posts: 1,043
Trader Rating: 17 (100%+)
Default

Sounding pretty bad that this is a common occurrence with these motors
Who knows if they are just a bad batch or a fault, won't be purchasing Another in the meanwhile
__________________
Team Awesomatix
R1 Wurks
RC Maker.com
Southern Tasmania Model Car Club
lethallee69 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LRP Vector x12 Brushless Motors mok Electric On-Road 697 08-04-2013 01:35 PM
LRP Vector X12 StockSpec and SXX stockspec mac853 Electric On-Road 224 03-27-2010 02:54 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net