Go Back  R/C Tech Forums > General Forums > Electric On-Road
Question - Muchmore Racing CTX-P Power Master World Ed >

Question - Muchmore Racing CTX-P Power Master World Ed

Question - Muchmore Racing CTX-P Power Master World Ed

Old 06-20-2011, 04:52 PM
  #1  
Tech Master
Thread Starter
iTrader: (2)
 
ByteStream's Avatar
 
Join Date: Jan 2010
Location: 5280 Raceway
Posts: 1,146
Trader Rating: 2 (100%+)
Default Question - Muchmore Racing CTX-P Power Master World Ed

So I just got one of these, got it out of the box, plugged it in and the fan started running and it runs constantly. It is pretty quiet, but still .. it always runs. There is no charger connected to it or anything else.

The description says that it has a "Temperature controlled cooling fan"? Not sure what that means if the fan is always on.

Is there something wrong with mine, or does everyone's do this?
ByteStream is offline  
Old 06-20-2011, 06:28 PM
  #2  
Tech Apprentice
 
MattFromSooke's Avatar
 
Join Date: Feb 2010
Location: Victoria, BC
Posts: 77
Default

both mine have done that since day 1. i have the Worlds edition 1 & 2 and no issues. better it stay on then stay off.
MattFromSooke is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.