R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 10-04-2004, 12:46 PM   #1
Tech Rookie
 
Join Date: Oct 2004
Location: London, England.
Posts: 9
Default Car For Free

Hmm wrong section I know but I joined up to the forums today. I wanted to get my RC Team Losi Street Weapon car working again, but no joy. My knowledge on RC cars isn't very good and I've threaded a couple of the screws. The car is doing my head in lol.

If someone wants to come by my house they can have the car and all the bits with it. Got a DCLine speed controller, SANWA AM Receiver, Saber handset, battery cells for the car, a charger which can use the car lighter as well as the mains, quite a few wheels, a motor etc etc.

PM me if your interested.

Cheers.
liberty is offline   Reply With Quote
Old 10-04-2004, 12:59 PM   #2
Tech Rookie
 
Join Date: Oct 2004
Location: London, England.
Posts: 9
Default

Like I said you can have the whole lot, I don't want or have a need for it any more and it's just taking up space. I'm sure some of you lot would have uses for it.
liberty is offline   Reply With Quote
Old 10-04-2004, 01:07 PM   #3
Tech Elite
 
GundamWZero's Avatar
 
Join Date: May 2004
Location: Ft. Bliss, Texas
Posts: 4,718
Trader Rating: 4 (100%+)
Send a message via MSN to GundamWZero Send a message via Yahoo to GundamWZero Send a message via Skype™ to GundamWZero
Default

First lets see if we can help pou get moving before you part with it. I am sure we here can help you fix your problems. What is wrong with it, ESC, motor,what?
__________________
"People tend to get upset because they don't get what they ask for... then complain when they get what they deserve." - R.E.Jacobs

‎"We fight not because we hate what's in front of us...
We fight to protect whats behind us."
GundamWZero is offline   Reply With Quote
Old 10-04-2004, 01:11 PM   #4
Tech Rookie
 
Join Date: Oct 2004
Location: London, England.
Posts: 9
Default

Well there was no power going forwards like not a response. Using a volt meter there were readings coming out of the blue and white leads from the speed controller. But the motor wasn't moving.

Don't have the right allen keys but have a set. Some of the screws were previously semi threaded and some are now completely threaded I think.

Just doing my head in and I don't want it lol
liberty is offline   Reply With Quote
Old 10-04-2004, 01:18 PM   #5
Tech Regular
 
Join Date: Sep 2004
Location: Las Vegas, NV
Posts: 435
Trader Rating: 1 (100%+)
Send a message via AIM to minijosh Send a message via Yahoo to minijosh
Default

HAHA I was first in line for something. This is weird. I don't know how to act.
__________________
http://rccarparts.biz/

Joshua T
minijosh is offline   Reply With Quote
Old 10-04-2004, 05:48 PM   #6
Tech Elite
 
Join Date: Jun 2003
Location: MOBILE.AL
Posts: 3,424
Trader Rating: 59 (100%+)
Send a message via AIM to nitro kid
Default

can you send me the car if so e-mail me at [email protected]
nitro kid is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
RCSignup.com - FREE Race Registration - FREE Track Profiles - FREE Racer Profiles superpb Web Links 3 01-16-2008 02:15 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net