R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-27-2004, 02:02 AM   #1
Suspended
 
Join Date: Mar 2003
Location: Back That Thang Up!
Posts: 3,468
Trader Rating: 11 (100%+)
Default Integy Customer Service?

ANyone have any experience with Integy's customer service?

I have an Indy 16x7v6 charger that simply died on me after 5 months of weekend use.
403forbidden is offline   Reply With Quote
Old 09-27-2004, 05:58 AM   #2
Tech Elite
 
seaball's Avatar
R/C Tech Charter Subscriber
 
Join Date: Sep 2001
Posts: 4,303
Trader Rating: 9 (100%+)
Send a message via Yahoo to seaball
Thumbs down

i have called and emailed them regarding parts that are not in stock, and have never received a reply.

with the exception of some of their products, i think they suck.
__________________
*** The Gate II - Home of Mike Wise ***
seaball is offline   Reply With Quote
Old 09-27-2004, 06:01 AM   #3
Suspended
 
Join Date: Mar 2003
Location: Back That Thang Up!
Posts: 3,468
Trader Rating: 11 (100%+)
Default

oh damn

Well I just placed an order for a CE Pitbull x3 'cuz I need a charger for this weekend.

IF Integy don't fix this problem I will be pissed.
403forbidden is offline   Reply With Quote
Old 09-27-2004, 06:06 AM   #4
Tech Master
 
Essnowyt's Avatar
 
Join Date: Apr 2004
Location: Somewhere Strange Wisconsin!
Posts: 1,662
Send a message via AIM to Essnowyt
Default

Yes I have had experience with Integy's customer service. A few years ago i send my charge to them, I think it was a 16x2, but it was sent the them for a upgrade. Well a few weeks went by I got it back and it did not charge. I sent them emails, they replied back with directions on how to operate the device. I sent the unit back to them. A week or so went by and I received the charger again. This time it actually charged like it was suppose to. I did not receive a letter of apology or any stickers. Integy's customer service did fix my prob. Because of the time I spent dealing with this, along with the problem in general, I no longer buy any Integy equipment.
Snowy.
__________________
Team XRay, RCAmerica, Motiv, Gravity RC, Schacht Design Works.

Drive it, Dont slide it!
Essnowyt is offline   Reply With Quote
Old 09-27-2004, 07:26 AM   #5
Tech Elite
 
Lonestar's Avatar
 
Join Date: Oct 2001
Location: Switzerland
Posts: 2,367
Trader Rating: 13 (100%+)
Default

Integy's CS anecdote:

My buddy bought a charger from them. He said he wanted to remove the cheap Tam plugs to put some nicer connectors on there (running deans 4-pins at the time). The Integy Tech's answer was "sorry it voids the warranty (which is usual with charger mf'ers) because it changes the impedance of the charge line (which is also true, but pointless), which in turns messes up the charger's software (which is total BS)". We (being both in the EE business) couldn't get the guy to change his opinions.

Draw your own conclusions

Paul
__________________
When the flag drops, the BS stops.

The train stops at the train station. The bus stops at the bus station. In my office I have a workstation.
Lonestar is offline   Reply With Quote
Old 09-27-2004, 07:29 AM   #6
Suspended
 
Join Date: Mar 2003
Location: Back That Thang Up!
Posts: 3,468
Trader Rating: 11 (100%+)
Default

oh damn...I changed the plugs as well...looks bad now
403forbidden is offline   Reply With Quote
Old 09-27-2004, 07:35 AM   #7
Tech Elite
 
ALBERTO's Avatar
 
Join Date: Aug 2004
Location: LONG ISLAND, NEW YORK
Posts: 2,986
Trader Rating: 23 (96%+)
Send a message via AIM to ALBERTO Send a message via Yahoo to ALBERTO
Default

I had sent them my indi 16x7v6 also. It had just shut down and never turned on. I spoke to A tech via email he gave me a few things to look at . After all was said and done I had to send the charger to them. It took like 3 weeks before I saw or heard a thing . Since then the charger has opperated flawlessly. Cant say the customer service was bad ..... Just slow. Lesson learned I now have a few extra chargers just in case
__________________
still fishing
ALBERTO is offline   Reply With Quote
Old 09-27-2004, 07:53 AM   #8
Suspended
 
Join Date: Mar 2003
Location: Back That Thang Up!
Posts: 3,468
Trader Rating: 11 (100%+)
Default

ALBERTO, what things did the tech tell you to look at?
403forbidden is offline   Reply With Quote
Old 09-27-2004, 04:29 PM   #9
Suspended
 
Join Date: Mar 2003
Location: Back That Thang Up!
Posts: 3,468
Trader Rating: 11 (100%+)
Default

does anyone onw if Integy has their own forum for support?
403forbidden is offline   Reply With Quote
Old 09-27-2004, 04:33 PM   #10
Tech Master
 
soc123_au's Avatar
R/C Tech Charter Subscriber
 
Join Date: Jul 2003
Location: Penrith Australia
Posts: 1,554
Trader Rating: 2 (100%+)
Default

Quote:
Originally posted by 403forbidden
does anyone onw if Integy has their own forum for support?
www.integy.com there is a link to a forum. I dont know how good it is. I have read a lot of it but never posted.
__________________
Serpent Radio Control Models
Auswide Hobbies
JPM Racing
soc123_au is offline   Reply With Quote
Old 09-27-2004, 04:53 PM   #11
Tech Elite
 
ALBERTO's Avatar
 
Join Date: Aug 2004
Location: LONG ISLAND, NEW YORK
Posts: 2,986
Trader Rating: 23 (96%+)
Send a message via AIM to ALBERTO Send a message via Yahoo to ALBERTO
Default

He said to open it up and look for any loose connections. Suck as that thin wire that follows the thicker one to the clips for charging. Well the tech said they were coming unsoldered easly. In some cases cold soldered. He said to resolder and see whats up if it still didn't work I would have to send it in.....
__________________
still fishing
ALBERTO is offline   Reply With Quote
Old 09-27-2004, 06:12 PM   #12
Regional Moderator
 
kumpol's Avatar
 
Join Date: Mar 2004
Location: Atlanta, Georgia
Posts: 970
Trader Rating: 1 (100%+)
Default

Integy forums
kumpol is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LRP Customer service. RON F Electric Off-Road 32 03-15-2012 01:54 PM
Customer Service.... iskandarfaisal Singapore R/C Racers 36 05-19-2007 01:09 PM
CRC Customer Service hyperdrivepro Chat Lounge 2 12-16-2006 04:38 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net