R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-18-2004, 03:18 PM   #1
Tech Regular
 
Join Date: Jun 2004
Posts: 499
Default trinity brushes suck

i just got my comm cut and they guy sold me a set of trinity brushes, because i needed softer brushes since my comm only has about 2 more cuts on it, last time i was using the reedy actron cavity brushes and they were great but these or horrible, my car drives like the comm needs to be cut again and i'm only 1 run in, i will never buy these again
kh15 is offline   Reply With Quote
Old 09-18-2004, 03:29 PM   #2
Tech Master
 
onnetz's Avatar
 
Join Date: Apr 2004
Posts: 1,727
Default

different motors react differently to different brushes.
did you seat them correctly?
do you have the right springs for the brushes?
which ones are they? trinity has quite a few brushes
what motor?
uneducated statements accomplish nothing..
onnetz is offline   Reply With Quote
Old 09-18-2004, 03:33 PM   #3
Tech Regular
 
Join Date: Jun 2004
Posts: 499
Default

team orion element 19t mod
trinity 4500
team matrix 200g springs
thier seated correctly i'm pretty sure thier not getting caught up on anything?
kh15 is offline   Reply With Quote
Old 09-18-2004, 03:57 PM   #4
Tech Master
 
PIIHB!'s Avatar
 
Join Date: Aug 2001
Location: South York/Red Lion, pa
Posts: 1,937
Trader Rating: 9 (100%+)
Default

kh15-You do realize a comm can be too small even tho there is still copper left on it. Mic your comm and tell us how small it is.
PIIHB! is offline   Reply With Quote
Old 09-18-2004, 04:01 PM   #5
Tech Regular
 
Join Date: Jun 2004
Posts: 499
Default

yes its at .276 its still got copper on it?
i think its the brushes ( which i did cut the little screw holes off so i could solder them on ) because this element motor is pretty quick but its just running like you would expect a car to run on a low battery?
also, and i dont know if this has anything to do about it but when i put my armature back in the can and this happens everytime and i put the pinnion back on and spin it by hand i think the armature is scrapping against the magnents but after you spin it like 5 times it all back to normal? the armature does have silver rings around it where i looks like it was scrapping?

Last edited by kh15; 09-18-2004 at 04:11 PM.
kh15 is offline   Reply With Quote
Old 09-18-2004, 04:27 PM   #6
Tech Regular
 
Join Date: Jun 2004
Posts: 499
Default

should i use some softer springs i still have the rtr tc3 springs that came on the stock motor
kh15 is offline   Reply With Quote
Old 09-18-2004, 04:43 PM   #7
Tech Master
 
onnetz's Avatar
 
Join Date: Apr 2004
Posts: 1,727
Default

try it... what have you got to lose?
also with the comm getting smaller you begin to lose torque and gain rpm's..
so along with softer brushes and springs you might try going down a tooth on the pinion to get more rpm's..
learn through experimenting instead of just taking someone else's word for it on whats best..
I enjoy trying different things with setups and motors as much as I do driving.
onnetz is offline   Reply With Quote
Old 09-18-2004, 07:25 PM   #8
Tech Addict
 
onebeatuptc3's Avatar
 
Join Date: Mar 2004
Location: Outside Peachtree city in GA
Posts: 552
Trader Rating: 3 (100%+)
Send a message via AIM to onebeatuptc3
Default

could it be the magnets need to be rezapped? Im just taking a stab in the dark here, but its a thought because it sounds like this motor has been used alot.
onebeatuptc3 is offline   Reply With Quote
Old 09-18-2004, 07:36 PM   #9
Tech Regular
 
Join Date: Jun 2004
Posts: 499
Default

okay i will try softer springs and let you know how it goes and my
motor only has about 20 runs on it, i have gotten my comm cut twice and the guy who cuts it said it can be cut about 2 more times before i have to buy another arm? i though i could get like 20 cuts out of it????
kh15 is offline   Reply With Quote
Old 09-18-2004, 07:50 PM   #10
Registered User
 
Join Date: Jul 2004
Location: Florida
Posts: 244
Send a message via AIM to T Allen
Default

there are many things that can be wrong with a motor and if the brushes are softer that means they have more copper and less silver that is why they are slow it is not because trinity sucks
T Allen is offline   Reply With Quote
Old 09-18-2004, 07:58 PM   #11
Tech Regular
 
Join Date: Aug 2004
Location: SCS Michigan
Posts: 327
Default

thats all i use is trinity and sometimes putum but mostly trinity, my car is so fast. you must be doing something wrong!!
Tony Szep is offline   Reply With Quote
Old 09-18-2004, 09:33 PM   #12
Tech Elite
 
fatdoggy's Avatar
R/C Tech Charter Subscriber
 
Join Date: Aug 2001
Location: MD USA
Posts: 3,642
Default

kh15 - Sounds like your getting screwed, you should be getting quite a bit more then 40 runs out of an arm provided your not abusing it. You can take the comm down to .270.
fatdoggy is offline   Reply With Quote
Old 09-18-2004, 09:36 PM   #13
Tech Regular
 
Join Date: Aug 2004
Location: Dallas,Texas
Posts: 459
Default

I am using 4505's and have to cut the comm and use new brushes after every run because the serrations wear out too quickly.
mtc3od is offline   Reply With Quote
Old 09-18-2004, 10:12 PM   #14
Tech Adept
 
hugh janus's Avatar
 
Join Date: Feb 2004
Location: ga
Posts: 127
Default

well trinitys' customer service suks and that is enough for me not to buy their brushes!
hugh janus is offline   Reply With Quote
Old 09-18-2004, 10:31 PM   #15
Tech Regular
 
Join Date: Feb 2002
Posts: 388
Send a message via ICQ to MaverickRacing
Default

You dont have to cut the comm and rebrush just because the serrations are gone. Your serrations are wearing out quickly because your springs are too heavy, or you are overgeared.

kh15 if anything you would need stiffer springs in order for the brushes to make contact with the comm. Did you solder the brushes to the brush hoods?
MaverickRacing is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trinity P94 XXX brushes v0rtex Australia For Sale/Trade 0 07-07-2006 06:34 PM
Trinity Brushes Tornado_Racing R/C Items: For Sale/Trade 0 05-20-2004 04:07 PM
Trinity Brushes Tornado_Racing R/C Items: For Sale/Trade 5 04-23-2004 03:43 AM
Trinity Brushes Tornado_Racing R/C Items: For Sale/Trade 0 04-08-2004 08:00 AM
Trinity Brushes, Brushes, Brushes Tornado_Racing R/C Items: For Sale/Trade 5 03-04-2004 08:48 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:23 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net