R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 03-21-2011, 04:15 PM   #1
Tech Rookie
 
Join Date: Mar 2011
Posts: 2
Default setup issues

I have a Tc5 and im currently having a steering problem. ill drive straight and it will start to veer to the right, so i turn left the next thing i know im going straight then it starts veering left? it goes back and forth sometimes it will go straight or veer right or left? any ideas what i need to adjust?
Baseballox34 is offline   Reply With Quote
Old 03-21-2011, 04:57 PM   #2
Tech Apprentice
 
digitrc's Avatar
 
Join Date: Jan 2011
Location: UK
Posts: 71
Default

Quote:
Originally Posted by Baseballox34 View Post
I have a Tc5 and im currently having a steering problem. ill drive straight and it will start to veer to the right, so i turn left the next thing i know im going straight then it starts veering left? it goes back and forth sometimes it will go straight or veer right or left? any ideas what i need to adjust?
Most likely problem is with the steering setup. Could be a weak or badly fitting servo saver, or binding in the steering mechanism, or a bad servo. It's very important that the steering system centres precisely with minimal resistance, otherwise the car will wander in different directions after corners.
__________________
David Allen - www.digitrc.co.uk - Xevo - Much-More Racing UK
digitrc is offline   Reply With Quote
Old 03-21-2011, 05:00 PM   #3
Tech Master
 
Chaz955i's Avatar
 
Join Date: May 2009
Location: NE Ohio
Posts: 1,021
Trader Rating: 5 (100%+)
Default

Quote:
Originally Posted by Baseballox34 View Post
I have a Tc5 and im currently having a steering problem. ill drive straight and it will start to veer to the right, so i turn left the next thing i know im going straight then it starts veering left? it goes back and forth sometimes it will go straight or veer right or left? any ideas what i need to adjust?
also check CVA's for binding and check hub bearings. Any drag on one side or another can make the car act funny.
__________________
At The Gate Bizzos
Chaz955i is offline   Reply With Quote
Old 03-22-2011, 08:26 PM   #4
Tech Rookie
 
Join Date: Mar 2011
Posts: 2
Default answer

it turned out to be something stupid. the guy who set it up who i got it from put the C hubs on the wrong sides and once i flipped them it drove perfectly straight no issues.
Baseballox34 is offline   Reply With Quote
Old 03-23-2011, 07:09 AM   #5
2xs
Tech Adept
 
Join Date: Feb 2010
Posts: 198
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Baseballox34 View Post
it turned out to be something stupid. the guy who set it up who i got it from put the C hubs on the wrong sides and once i flipped them it drove perfectly straight no issues.
Same thing happened to me with a used TCX.
2xs is offline   Reply With Quote
Old 03-23-2011, 07:39 AM   #6
Tech Elite
 
Foxxrocket's Avatar
 
Join Date: Jul 2008
Location: Sonoma County
Posts: 2,018
Default

Quote:
Originally Posted by Baseballox34 View Post
it turned out to be something stupid. the guy who set it up who i got it from put the C hubs on the wrong sides and once i flipped them it drove perfectly straight no issues.
Good thing you found the problem. Because a hundred different things could cause that to happen.
__________________
Tamiya 416X/ Tamiya TA-05 IFS/ Losi XXX-SCT/ HPI Baja 5SC/ Tamiya M05/ Tamiya F103/ Tamiya F104/ Team Associated 10R5O/ Kyosho IGT2/
Foxxrocket is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Team Associated SC8 Setup and Tips Cru_Jones Nitro Off-Road 888 03-07-2014 08:32 PM
Tekin Vegas 2.0 Setup and Support Randy_Pike Electric Off-Road 1713 12-06-2011 05:31 PM
Losi 8ight building and setup JBRacing Nitro Off-Road 8691 06-27-2011 09:43 AM
XRAY T1 Evo 2: Building Advice, or setup advice Carbon_Fibre3 Electric On-Road 9 01-03-2003 02:44 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net