R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-27-2004, 05:59 PM   #1
Tech Adept
 
Join Date: May 2004
Location: indiana
Posts: 242
Send a message via AIM to dasupacat
Default HELP! Novak N-power problem?

Hi
I'm getting back into the race seen and just bought a used Novak N-power on Ebay. When I plugged it in the fan doesn't come on. Last year i bought one brand new, but sold it cuz
I got out of hobby for awhile. Anyways if I remember correctly my 1st n-power always had the fan come on when I switched the power on. My question is should the fan always be on or does it come on only when it really heats up cuz I don't memba? It seems to put out power ok. The red led lights and i get power from the terminals (hooked up a small 12v fan). I have yet to hook up a charger (millenium pro on the way). I'll be pissed if
I need to send it in to Novak.
So please any n-power owners let me know.
Thanx David
dasupacat is offline   Reply With Quote
Old 08-27-2004, 06:44 PM   #2
The Evicerator
R/C Tech Elite Subscriber
 
Join Date: Sep 2001
Location: Irvine, CA
Posts: 4,142
Default

Newer N-Powers come equiped with fan-control circuitry that only turns the fan on when it is hot... you can try plugging in your N-power and heating it up with a Heat gun or blow drier to see if the fan turns on.
__________________
Steve Weiss
TEAM ASSOCIATED -- REEDY -- SANWA -- PROTOFORM -- 1UP Racing -- ActivRC -- P1 BRAND -- TEAM KINWALD -- TEAM STEVE INTERNATIONAL
Steve Weiss is offline   Reply With Quote
Old 08-27-2004, 07:38 PM   #3
Tech Regular
 
Qwiglee's Avatar
 
Join Date: Jul 2004
Location: Ventura, CA
Posts: 313
Default

I have used an N-Power for about a year and never even heard the fan. Maybe mine doesn't work but I have never had any trouble with it.
__________________
Brian Aldridge
Qwiglee is offline   Reply With Quote
Old 08-28-2004, 04:40 PM   #4
Tech Adept
 
Join Date: May 2004
Location: indiana
Posts: 242
Send a message via AIM to dasupacat
Default

Well that makes me feel a lil' betta. Just worried cuz it's used. Can nybody else out there who own's one give there thoughts?
Thanx David
dasupacat is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power-capacitor problem (LRP Sphere) Calle Pe Radio and Electronics 0 07-03-2008 12:18 PM
Power Problem juneau Australian Racing 13 01-16-2008 03:43 PM
Power supply problem and questions ken39 Singapore R/C Racers 6 03-08-2006 02:56 AM
Weird power supply problem micros_rock Electric On-Road 9 07-29-2004 01:20 AM
Power supply problem warlord385 Electric On-Road 4 02-10-2003 10:50 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:25 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net