Go Back  R/C Tech Forums > General Forums > Electric On-Road
Jaco Blues...They worked for me! No defects >

Jaco Blues...They worked for me! No defects

Jaco Blues...They worked for me! No defects

Old 01-24-2011, 12:18 PM
  #1  
Tech Addict
Thread Starter
iTrader: (5)
 
fox88gt's Avatar
 
Join Date: Mar 2009
Location: FDL, WI
Posts: 527
Trader Rating: 5 (100%+)
Default Jaco Blues...They worked for me! No defects

Recently there has been discussion of defective Jaco's, it happened to me even, but my last set were EXCELLENT.

Just finished a round of the Hurricane Series and my Jaco Blues worked perfectly. World stock sedan, carpet, corally rdx, mazda 6 body, 17.5 zero timing. No strange wear and no defects. Car felt balanced and had consistent grip. Took me to the A main and there is plenty of life left in them for club racing.

I'm not affiliated with Jaco - just wanted to share my experience.

Jeff
fox88gt is offline  
Old 01-24-2011, 09:26 PM
  #2  
Tech Adept
iTrader: (15)
 
xray2050's Avatar
 
Join Date: Oct 2009
Posts: 237
Trader Rating: 15 (100%+)
Default

Personally I haven't had any issues with them. I did see one blow apart once but after looking over the tires on that car it looked like there was excessive camber being used which caused the blow-out. This past weekend I used Jaco Blues at the Canadian Indoor Nationals and finished 3rd in A main 17.5.
This was an open tire event. These tires worked great and had lots of grip. No complaints either.
xray2050 is offline  
Old 01-24-2011, 09:59 PM
  #3  
Tech Master
iTrader: (1)
 
locked's Avatar
 
Join Date: Mar 2010
Location: Toronto
Posts: 1,758
Trader Rating: 1 (100%+)
Default

Originally Posted by xray2050 View Post
Personally I haven't had any issues with them. I did see one blow apart once but after looking over the tires on that car it looked like there was excessive camber being used which caused the blow-out. This past weekend I used Jaco Blues at the Canadian Indoor Nationals and finished 3rd in A main 17.5.
This was an open tire event. These tires worked great and had lots of grip. No complaints either.
The first set I ever tried tore apart on their 5th run, but I used my 2nd set at the nats and they were great there. I even traction rolled once with them at the end of the straight. I had trouble getting any other tires I had to not traction roll.

Congrats on the podium Pete.
locked is offline  
Old 01-25-2011, 12:10 AM
  #4  
Tech Adept
iTrader: (15)
 
xray2050's Avatar
 
Join Date: Oct 2009
Posts: 237
Trader Rating: 15 (100%+)
Default

Originally Posted by locked View Post
The first set I ever tried tore apart on their 5th run, but I used my 2nd set at the nats and they were great there. I even traction rolled once with them at the end of the straight. I had trouble getting any other tires I had to not traction roll.

Congrats on the podium Pete.
Thanks Dave.
As the traction really picked up for the last quailifier, I opted for a new set to maybe take a little traction away. It wasn't the right idea as my car developed quite a push for the first 3 or 4 laps. Oh well sometimes you make the wrong decision, wish it was at a club race though..
xray2050 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.