Go Back  R/C Tech Forums > General Forums > Electric On-Road
I tested my Evo 4.... >

I tested my Evo 4....

I tested my Evo 4....

Old 08-07-2004, 07:07 AM
  #1  
Tech Initiate
Thread Starter
 
Join Date: Aug 2004
Location: London
Posts: 20
Default I tested my Evo 4....

Hey, I tried out my TB Evo 4 last night, went like stink.
EVO4man is offline  
Old 08-07-2004, 07:40 AM
  #2  
Tech Master
iTrader: (1)
 
NVisible's Avatar
 
Join Date: Jan 2004
Location: Ontario, Canada
Posts: 1,188
Trader Rating: 1 (100%+)
Default

not
NVisible is offline  
Old 08-07-2004, 11:12 AM
  #3  
X2
Tech Regular
 
X2's Avatar
 
Join Date: Mar 2004
Location: England
Posts: 340
Default

X2 is offline  
Old 08-07-2004, 11:24 AM
  #4  
Tech Elite
iTrader: (4)
 
GundamWZero's Avatar
 
Join Date: May 2004
Location: Ft. Bliss, Texas
Posts: 4,718
Trader Rating: 4 (100%+)
Default

I have no usefull information from this thread.............
GundamWZero is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.