R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-10-2010, 03:58 AM   #1
Tech Regular
 
Brum's Avatar
 
Join Date: Aug 2008
Location: Goldcoast
Posts: 400
Trader Rating: 1 (100%+)
Send a message via ICQ to Brum
Questions?? confused novak

Hi all still cant work out whats going on with my novak setup.
novak kinetic 2s and novak ballistic 4.5t 550 motor.
I finally got power to my esc again after leaving it unplugged overnight.
when i turn my esc on all the lights come on go through there sequence
and show no errors. i pull the throttle and the motor runs for about 3seconds
then stops and all the lights go out and esc will not switch back on.
i have to diconnect the battery wait 1-2 hours hook it back up and esc works again pull the throttle and it does it all over again what am i doing wrong i have tried sevaral battery packs and recievers makes no difference
my sevo is new ace 1015 please help thanx.
__________________
__________________
Mugen eco 6,Castle Mamba.Kopropo.EX-1.
Shumacher cougar svr..tekin rs pro,redline 8.5t.Kopropo.EX-1
Shumacher K1 tekin rs pro,redline 7.5t, Kopropo,EX-1
member of Logan Offroad LORRCCC inc.
Brum is offline   Reply With Quote
Old 09-10-2010, 06:52 AM   #2
Tech Regular
 
scoyle's Avatar
 
Join Date: Jan 2004
Location: Northern Ireland
Posts: 465
Default

Hi, don't know the answer to your query but you may want to ask it in the Kinetic thread;

http://www.rctech.net/forum/electric...inetic-54.html

There are a number of Novak people on there.
scoyle is offline   Reply With Quote
Old 09-10-2010, 08:15 AM   #3
Company Representative
R/C Tech Elite Subscriber
 
Join Date: Jun 2005
Location: SoCal
Posts: 2,891
Default

Quote:
Originally Posted by Brum View Post
Hi all still cant work out whats going on with my novak setup.
novak kinetic 2s and novak ballistic 4.5t 550 motor.
I finally got power to my esc again after leaving it unplugged overnight.
when i turn my esc on all the lights come on go through there sequence
and show no errors. i pull the throttle and the motor runs for about 3seconds
then stops and all the lights go out and esc will not switch back on.
i have to diconnect the battery wait 1-2 hours hook it back up and esc works again pull the throttle and it does it all over again what am i doing wrong i have tried sevaral battery packs and recievers makes no difference
my sevo is new ace 1015 please help thanx.
__________________
Because I am not part of Novak's technical support group, I suggest you email [email protected] with your question, Our regular CS/Tech Support hours can be located here. Before emailing, take a moment to review the instructions (trouble-shooting guide) originally included with your Novak Item:

Novak Instruction Downloads

Trouble-shooting TeamNovak's One Touch™ Speed Controls

Quote:
Please make your initial email as detailed as possible. Include:

~ speed control (brand/model)
~ motor (brand/wind)
~ number/type of cells
~ battery, brand (c rating/capacity
~ rotor (old/new)
~ connectors used
~ servo (brand/model)
~ radio system (receiver/transmitter)
~ vehicle & gearing
~ warranty claim?
~ lipo cut-off, on/off
~ any external modules (BEC/brand, Glitch Buster)
~ other important info: water damage, corrosive chemical sprays, excess heat, etc
The more information you provide in your first email, the more quickly tech support can offer you assistance.
NovakTwo is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Novak Brusless System danjoy25 Electric On-Road 2688 10-14-2010 09:40 AM
Official: Novak's 1/8 Scale Nitro to Electric Conversion Kits NovakTwo Electric Off-Road 1144 01-04-2010 04:49 AM
NOVAK U.S. TOURING CAR CHAMPIONSHIPS January 3 - 7 NOTHIN BUT AIR Electric On-Road 453 01-11-2007 01:38 PM
2006 U.S. Touring Car Championships - Novak Race nashrcracer Electric On-Road 746 02-09-2006 04:05 PM
R/C Tech Live @ the 2005 Novak US Touring Car Championships futureal Electric On-Road 1079 01-28-2005 03:20 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net