Go Back  R/C Tech Forums > General Forums > Electric On-Road
Diamond Bit Question >

Diamond Bit Question

Diamond Bit Question

Old 06-14-2004, 08:46 PM
  #1  
Tech Regular
Thread Starter
 
new92's Avatar
 
Join Date: Jan 2003
Location: Middleburg (Jax), FL
Posts: 356
Default Diamond Bit Question

I just got a Team Cobra lathe with a diamond bit. When I was setting it up and took the bit out it has a green waxy substance on the tip. What is it and how do I get it off. I assume its wax to protect the tip, but I didnt want to take a lighter or something to it until I asked
new92 is offline  
Old 06-14-2004, 09:16 PM
  #2  
Moderator
iTrader: (8)
 
StephenSobottka's Avatar
 
Join Date: Jul 2002
Location: Milwaukee, WI
Posts: 3,267
Trader Rating: 8 (100%+)
Default

I used some rubbing alcohol and a rag to clean it off.
StephenSobottka is offline  
Old 06-14-2004, 09:23 PM
  #3  
Tech Regular
Thread Starter
 
new92's Avatar
 
Join Date: Jan 2003
Location: Middleburg (Jax), FL
Posts: 356
Default

Thanks
new92 is offline  
Old 06-16-2004, 12:56 PM
  #4  
Tech Fanatic
 
rcsabah's Avatar
 
Join Date: Jul 2002
Location: TQ around de World
Posts: 996
Default

i have one but i tear it off. remember to oil the bit if not it will get rust very fast
rcsabah is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.