R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-11-2010, 08:35 AM   #1
Tech Elite
 
haywood's Avatar
 
Join Date: Dec 2008
Location: Minnesota
Posts: 2,809
Trader Rating: 49 (100%+)
Default Servo problem

I installed a new esc in my touring car and now the servo just flips out. I bind up my specktrum radio and receiver and as soon I touch the steering it loses bind. The servo worked fine at my last race but I tried another servo and it works just fine.Any ideas or is my $100 Orion servo junk!
__________________
Calandra Racing Concepts/ Hobbywing / Team Scream / Progressive Rc / Ko Propo / MotivRc / Dri-Fit Mafia /
haywood is offline   Reply With Quote
Old 08-11-2010, 08:58 AM   #2
Tech Elite
 
sosidge's Avatar
 
Join Date: Dec 2001
Location: Bristol, UK
Posts: 3,865
Default

Do you have the Spektrum Cap?

What is the new ESC? And what was the old one?
sosidge is offline   Reply With Quote
Old 08-11-2010, 09:03 AM   #3
Tech Elite
 
haywood's Avatar
 
Join Date: Dec 2008
Location: Minnesota
Posts: 2,809
Trader Rating: 49 (100%+)
Default

Old esc was a lrp spx and the new is a mmp and no spectrum cap. Thanks
__________________
Calandra Racing Concepts/ Hobbywing / Team Scream / Progressive Rc / Ko Propo / MotivRc / Dri-Fit Mafia /
haywood is offline   Reply With Quote
Old 08-11-2010, 09:42 AM   #4
Tech Elite
 
sosidge's Avatar
 
Join Date: Dec 2001
Location: Bristol, UK
Posts: 3,865
Default

I'll hazard a guess that the MMP is not supplying the voltage/current required for the Orion servo, whereas the LRP has a very strong 6V/3A BEC output.

The spektrum cap will help to smooth out the power supply and may solve the problem. You may be able to try a different setting on the Mamba Max Pro (I'm not familiar with the speedo personally, but I see that they mention a programmable BEC voltage on their website).

If neither is a solution, you're going to have to wave goodbye to the Orion and find a less power-hungry servo for the car.
sosidge is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
xp 1015 servo problem nitrobhoy Radio and Electronics 30 04-11-2010 08:39 PM
Mini LST2 servo problem... Dragon99 Micro and Mini Scales 8 02-10-2009 11:47 PM
SERVO PROBLEM lancerevo22194 Micro and Mini Scales 11 07-23-2008 04:17 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net