Go Back  R/C Tech Forums > General Forums > Electric On-Road
Help w TA02 rear diff not working >

Help w TA02 rear diff not working

Help w TA02 rear diff not working

Old 07-20-2010, 12:47 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jul 2010
Posts: 1
Default Help w TA02 rear diff not working

Hi. I have a Tamiya TA02 Castrol Celica WRC car... got it out after a long storage, been a lot of fun, but now the rear diff isn't working at all. It's basically FWD. The main driveshaft is still there, but no power to the rear wheels. I can also rotate a rear wheel, without the other rear wheel turning. Did I strip some gears? Where do I order a replacement kit?

Thanks in advance!
cash68 is offline  
Old 07-20-2010, 12:49 PM
  #2  
Tech Apprentice
iTrader: (1)
 
Join Date: Jul 2009
Posts: 80
Trader Rating: 1 (100%+)
Default

Originally Posted by cash68 View Post
Hi. I have a Tamiya TA02 Castrol Celica WRC car... got it out after a long storage, been a lot of fun, but now the rear diff isn't working at all. It's basically FWD. The main driveshaft is still there, but no power to the rear wheels. I can also rotate a rear wheel, without the other rear wheel turning. Did I strip some gears? Where do I order a replacement kit?

Thanks in advance!
I think you might of stripped the spines on the diff plate where the drive cups attach to. check that first.
tpsolid is offline  
Old 07-20-2010, 06:25 PM
  #3  
Tech Regular
iTrader: (1)
 
RossoTorro's Avatar
 
Join Date: Dec 2008
Location: Euro-Thrash
Posts: 400
Trader Rating: 1 (100%+)
Default

Manta Ray balldiff in the rear, change it to a TA03 balldiff.
Metal of the Manta Ray is softer than in the TA03 diff. Use the diff cups from Manta Ray of they are not worn out as they are stronger than TA03....
It's a common problem with stripped splines on Manta Ray diffs.
RossoTorro is offline  
Old 07-21-2010, 02:40 AM
  #4  
Tech Elite
 
niznai's Avatar
 
Join Date: Feb 2009
Location: All over the place
Posts: 2,965
Default

Originally Posted by tpsolid View Post
I think you might of stripped the spines on the diff plate where the drive cups attach to. check that first.
Either that or the diff has worked itself loose. If the splines are OK, then you need to open the rear gearbox and have a look.
niznai is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.