Go Back  R/C Tech Forums > General Forums > Electric On-Road
Team Associated TC6 Thread >

Team Associated TC6 Thread

Like Tree20Likes

Team Associated TC6 Thread

Old 04-06-2016, 10:46 PM
  #10246  
Tech Rookie
iTrader: (4)
 
afro_lou's Avatar
 
Join Date: Mar 2014
Posts: 11
Trader Rating: 4 (100%+)
Default

Originally Posted by tommysnow7
Recently bought a tc6.1 for usgt, does anyone have a setup for this class? Thanks
Sorry, I don't have a full setup sheet for you, but mine's set up as such:

Arm mounts as low as possible (1 dot on the lowest hole, or no dot on the upper hole)
-1 camber all around
30wt oil in the shocks w/softest springs (12.5lb, I think?)
As much droop as you can get
5.5mm ride height

I'm pretty new to this, but had some good help from an experienced usgt driver to get this setup.

Good luck!
afro_lou is offline  
Old 04-07-2016, 07:40 AM
  #10247  
Tech Elite
iTrader: (1)
 
Join Date: Sep 2010
Location: My house.
Posts: 3,569
Trader Rating: 1 (100%+)
Default

Originally Posted by phatboislim
get some extra offset arm mounts, one pack of front arms and a couple packs of front caster blocks...that should be pretty solid to hold u on any breakages. but in general if the chassis isnt twisted and everything looks ok and feels solid then it's probably ok
I only broke a rear hub so far so I would suggest them too, all TC6 parts except the diff.
30Tooth is offline  
Old 04-07-2016, 08:37 AM
  #10248  
Tech Master
iTrader: (26)
 
Join Date: Sep 2014
Posts: 1,767
Trader Rating: 26 (100%+)
Default

i've had my TC used and i've never broken a rear hub. i just replaced the offsets in them so there wouldnt be any play in the outer hinge pin

but i know everyone is different
phatboislim is offline  
Old 04-08-2016, 04:00 AM
  #10249  
Tech Elite
iTrader: (1)
 
Join Date: Sep 2010
Location: My house.
Posts: 3,569
Trader Rating: 1 (100%+)
Default

Originally Posted by phatboislim
i've had my TC used and i've never broken a rear hub. i just replaced the offsets in them so there wouldnt be any play in the outer hinge pin

but i know everyone is different
It was a TC6 hub and broke horizontally (along the axle) in a sideways crash, since then I never had another crash worth mentioning. Are you going to use TC7 arms? Would you kindly measure them?
30Tooth is offline  
Old 04-08-2016, 05:37 AM
  #10250  
Tech Master
iTrader: (26)
 
Join Date: Sep 2014
Posts: 1,767
Trader Rating: 26 (100%+)
Default

i'll measure it for you...you have to have a shit ton of shims too btw. but it is smaller than the TC6 arms by alot..i'd say probably about 10mm. i loosely followed Keven Herbert's setup. I'm also using the reflex shock towers...i have to reorder them unfortunately though.

http://site.petitrc.com/reglages/ass...ice2015121113/

phatboislim is offline  
Old 04-08-2016, 01:09 PM
  #10251  
Tech Master
 
Lone Drifter's Avatar
 
Join Date: May 2014
Location: SW Chicago Burbs
Posts: 1,268
Default

Originally Posted by cosmicpilot
some times my car pulls to the left on my tc6.1
can any one help please
I have also had where one of the CVD joints would stick just even a little and the car would spin our pull in one direction
A bent shock shaft sometimes will do that too.
Lone Drifter is offline  
Old 04-09-2016, 08:27 AM
  #10252  
Tech Elite
iTrader: (1)
 
Join Date: Sep 2010
Location: My house.
Posts: 3,569
Trader Rating: 1 (100%+)
Default

Originally Posted by phatboislim
i'll measure it for you...you have to have a shit ton of shims too btw. but it is smaller than the TC6 arms by alot..i'd say probably about 10mm. i loosely followed Keven Herbert's setup. I'm also using the reflex shock towers...i have to reorder them unfortunately though.

http://site.petitrc.com/reglages/ass...ice2015121113/

*snip*]
Thanks, really appreciate it.
If not asking too much would just need hinge pin to hinge pin length and shock hole to inner hinge pin length. I'm eager to find what are the big changes in that aspect.

Last edited by 30Tooth; 04-09-2016 at 08:30 AM. Reason: removed pic to not clutter the thread
30Tooth is offline  
Old 04-26-2016, 09:11 PM
  #10253  
Tech Initiate
 
Join Date: Feb 2008
Location: Baldwin park.. CA.
Posts: 46
Default

i broke many of the front c hubs on my tc6
nova69 is offline  
Old 06-25-2016, 04:56 AM
  #10254  
Tech Elite
iTrader: (15)
 
JEFFs SC10's Avatar
 
Join Date: Sep 2010
Location: Orlandooooo, Fl
Posts: 4,044
Trader Rating: 15 (100%+)
Default

Quick question, will the gear diff fit in my 6.1?

I bought this as my first TC car/ VTA car and it works great. liked it so much I bought the TC 7 lol.

Great car to learn on and they are cheap!
JEFFs SC10 is offline  
Old 06-25-2016, 05:32 AM
  #10255  
Tech Champion
iTrader: (2)
 
gigaplex's Avatar
 
Join Date: Dec 2015
Location: Melbourne, VIC
Posts: 6,037
Trader Rating: 2 (100%+)
Default

Originally Posted by JEFFs SC10
Quick question, will the gear diff fit in my 6.1?

I bought this as my first TC car/ VTA car and it works great. liked it so much I bought the TC 7 lol.

Great car to learn on and they are cheap!
The 6.1 comes with a gear diff. Which gear diff are you asking about?
gigaplex is offline  
Old 06-25-2016, 10:55 AM
  #10256  
Tech Elite
iTrader: (15)
 
JEFFs SC10's Avatar
 
Join Date: Sep 2010
Location: Orlandooooo, Fl
Posts: 4,044
Trader Rating: 15 (100%+)
Default

Oh I thought it had a ball diff, if that's the case then I just need to put some thicker diff fluid. Feels very loose. I run on high grip crc carpet.
JEFFs SC10 is offline  
Old 06-25-2016, 04:25 PM
  #10257  
Tech Champion
iTrader: (2)
 
gigaplex's Avatar
 
Join Date: Dec 2015
Location: Melbourne, VIC
Posts: 6,037
Trader Rating: 2 (100%+)
Default

Originally Posted by JEFFs SC10
Oh I thought it had a ball diff, if that's the case then I just need to put some thicker diff fluid. Feels very loose. I run on high grip crc carpet.
The 6 came with a ball diff, the 6.1 switched to a gear diff. Post a picture and we'll be able to tell you what you've currently got.
gigaplex is offline  
Old 06-25-2016, 06:38 PM
  #10258  
Tech Adept
iTrader: (7)
 
adriang79's Avatar
 
Join Date: Nov 2009
Location: Hobart, Tasmania
Posts: 180
Trader Rating: 7 (100%+)
Default

Originally Posted by cosmicpilot
some times my car pulls to the left on my tc6.1
can any one help please
Check your spool drive cups and drive blades on end of CVD. The plastic spool cups can be easily damaged and the drive blades snap. I use the steel spool cups from the TC6.2, no drive blades needed with this.
adriang79 is offline  
Old 06-25-2016, 10:38 PM
  #10259  
Tech Elite
iTrader: (15)
 
JEFFs SC10's Avatar
 
Join Date: Sep 2010
Location: Orlandooooo, Fl
Posts: 4,044
Trader Rating: 15 (100%+)
Default

Originally Posted by gigaplex
The 6 came with a ball diff, the 6.1 switched to a gear diff. Post a picture and we'll be able to tell you what you've currently got.
yup I got a gear diff. I'm a dumba.. I put in thicker lube as it felt like there was none in there. I run on high grip crc carpet so this should help.

Can I run the steel outdrives in the rear so I dont have to run those blades?
JEFFs SC10 is offline  
Old 07-01-2016, 04:34 PM
  #10260  
Tech Elite
iTrader: (15)
 
JEFFs SC10's Avatar
 
Join Date: Sep 2010
Location: Orlandooooo, Fl
Posts: 4,044
Trader Rating: 15 (100%+)
Default

Just an update, the change in the diff helped I TQ'd and won in VTA !

This old chassis gets the job done!

Originally Posted by JEFFs SC10
yup I got a gear diff. I'm a dumba.. I put in thicker lube as it felt like there was none in there. I run on high grip crc carpet so this should help.

Can I run the steel outdrives in the rear so I dont have to run those blades?
JEFFs SC10 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.