Go Back  R/C Tech Forums > General Forums > Electric On-Road
Speed Passion Cirtix Stock CLUB ESC > Speed Passion Cirtix Stock CLUB ESC

Speed Passion Cirtix Stock CLUB ESC

Reply

Old 05-30-2010, 08:28 AM
  #121  
Tech Adept
iTrader: (7)
 
Join Date: Oct 2004
Posts: 148
Trader Rating: 7 (100%+)
Default Herman

I had the same think with mine, what i did was keep trying and it did work. I have been to the track and all works. I have not driven in almost 2 years so can tell how good it work with my pooooooooooor driving. next time you try when you think you are done go one more time on the lights. Harold
edm rob is offline  
Reply With Quote
Old 05-30-2010, 12:09 PM
  #122  
Tech Addict
 
Deebs's Avatar
 
Join Date: May 2006
Location: Jamaica
Posts: 514
Default

Originally Posted by tino View Post
I can't get mine to set or work either,same track as technique 550,heard of one other at uor track that had trouble.Haven't been to track since they all came in so not sure oof the other 10 or so.
Herman - come by the Shop when u can and we'll get it sorted out
Deebs is offline  
Reply With Quote
Old 05-30-2010, 05:39 PM
  #123  
Tech Regular
 
Join Date: Oct 2007
Location: royal palm bch,fl.
Posts: 494
Default

Thanks!!I don't know if it matters but I use the older radio systems,no 2.4
tino is offline  
Reply With Quote
Old 05-30-2010, 08:10 PM
  #124  
Tech Regular
iTrader: (1)
 
Technique550's Avatar
 
Join Date: Feb 2009
Location: Boynton Beach Florida
Posts: 313
Trader Rating: 1 (100%+)
Cool good news

Yup Bob Husted is the man!!!! got mine going today works very well all it was the solder joint on the white wire at the esc it was hangin on by a thread maybe its the same with yours check em !!Oh and my sensor wires have a couple bad crimps had to use another sensor cable. I guess SP might have been a lil quick in bangin this batch out so go through it thoroughly
Technique550 is offline  
Reply With Quote
Old 05-31-2010, 04:32 AM
  #125  
Tech Regular
 
Join Date: Oct 2007
Location: royal palm bch,fl.
Posts: 494
Default

Thanks Smiley!
tino is offline  
Reply With Quote
Old 05-31-2010, 10:21 AM
  #126  
Tech Regular
iTrader: (3)
 
Conrad's Avatar
 
Join Date: Jun 2005
Location: Scotland
Posts: 499
Trader Rating: 3 (100%+)
Default

Originally Posted by Solara View Post
Winner of the past weekend ETS Round 5 Pro Stock Class....pictures by RedRC.



Thanks Solara!
Conrad is offline  
Reply With Quote
Old 05-31-2010, 10:48 AM
  #127  
Tech Addict
 
Deebs's Avatar
 
Join Date: May 2006
Location: Jamaica
Posts: 514
Default

Originally Posted by Technique550 View Post
Yup Bob Husted is the man!!!! got mine going today works very well all it was the solder joint on the white wire at the esc it was hangin on by a thread maybe its the same with yours check em !!Oh and my sensor wires have a couple bad crimps had to use another sensor cable. I guess SP might have been a lil quick in bangin this batch out so go through it thoroughly
Sweet - glad to hear that Rob!!
Deebs is offline  
Reply With Quote
Old 05-31-2010, 01:54 PM
  #128  
Tech Adept
 
Join Date: Sep 2009
Posts: 117
Default

Is this speedo as fast as mod motor ESCs without boost, such as LRP Sphere TC or SXX TC?
andrew188 is offline  
Reply With Quote
Old 05-31-2010, 02:43 PM
  #129  
Super Moderator
iTrader: (1)
 
charlie_b's Avatar
 
Join Date: Aug 2001
Location: Anaheim
Posts: 9,852
Trader Rating: 1 (100%+)
Default

Originally Posted by andrew188 View Post
Is this speedo as fast as mod motor ESCs without boost, such as LRP Sphere TC or SXX TC?
Possibly better.
charlie_b is offline  
Reply With Quote
Old 06-07-2010, 03:58 PM
  #130  
Tech Fanatic
iTrader: (35)
 
tiko's Avatar
 
Join Date: May 2008
Posts: 948
Trader Rating: 35 (100%+)
Default

I have been trying to program my Stock Spec ESC all day and it just wonít work. After going through all the steps the Red light stays on and nothing works. If I turn it off and back on both Red and the Yellow lights come on, the Red light flashes continuously and the Yellow is just on. I just got this ESC combo two days ago and so far Iím not liking it. I hope that it doesnít turnout to be a dud. If anyone has any suggestions please let me know it would be greatly appreciated.
tiko is offline  
Reply With Quote
Old 06-07-2010, 04:11 PM
  #131  
Tech Champion
iTrader: (73)
 
MikeXray's Avatar
 
Join Date: Oct 2006
Location: New York
Posts: 5,753
Trader Rating: 73 (100%+)
Default

Originally Posted by tiko View Post
I have been trying to program my Stock Spec ESC all day and it just wonít work. After going through all the steps the Red light stays on and nothing works. If I turn it off and back on both Red and the Yellow lights come on, the Red light flashes continuously and the Yellow is just on. I just got this ESC combo two days ago and so far Iím not liking it. I hope that it doesnít turnout to be a dud. If anyone has any suggestions please let me know it would be greatly appreciated.
try it with throttle reversed?
MikeXray is offline  
Reply With Quote
Old 06-07-2010, 04:18 PM
  #132  
Tech Fanatic
iTrader: (35)
 
tiko's Avatar
 
Join Date: May 2008
Posts: 948
Trader Rating: 35 (100%+)
Default

Originally Posted by MikeXray View Post
try it with throttle reversed?
I did not still working
tiko is offline  
Reply With Quote
Old 06-07-2010, 04:23 PM
  #133  
Tech Champion
iTrader: (73)
 
MikeXray's Avatar
 
Join Date: Oct 2006
Location: New York
Posts: 5,753
Trader Rating: 73 (100%+)
Default

Originally Posted by tiko View Post
I did not still working
What radio?
MikeXray is offline  
Reply With Quote
Old 06-07-2010, 05:39 PM
  #134  
Tech Fanatic
iTrader: (35)
 
tiko's Avatar
 
Join Date: May 2008
Posts: 948
Trader Rating: 35 (100%+)
Default

Originally Posted by MikeXray View Post
What radio?
Spektrum DX3S
tiko is offline  
Reply With Quote
Old 06-07-2010, 05:47 PM
  #135  
Tech Fanatic
iTrader: (67)
 
SRBMOJO's Avatar
 
Join Date: Jul 2007
Location: ORANGE CO., CA
Posts: 977
Trader Rating: 67 (100%+)
Default

Originally Posted by tiko View Post
I have been trying to program my Stock Spec ESC all day and it just wonít work. After going through all the steps the Red light stays on and nothing works. If I turn it off and back on both Red and the Yellow lights come on, the Red light flashes continuously and the Yellow is just on. I just got this ESC combo two days ago and so far Iím not liking it. I hope that it doesnít turnout to be a dud. If anyone has any suggestions please let me know it would be greatly appreciated.
same symptoms as you, excet when I turn it off, then on it works fine. The lights are on and flashing at startup, but everything works on the track. I have a Futaba 3PM.
SRBMOJO is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service